aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/squidclamav/Makefile35
-rw-r--r--www/squidclamav/distinfo2
-rw-r--r--www/squidclamav/files/patch-etc-Makefile.in10
-rw-r--r--www/squidclamav/pkg-descr27
-rw-r--r--www/squidclamav/pkg-plist15
6 files changed, 90 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 6e5b8200bbe8..54bed9686f14 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1796,6 +1796,7 @@
SUBDIR += squid
SUBDIR += squid31
SUBDIR += squid_radius_auth
+ SUBDIR += squidclamav
SUBDIR += squidguard
SUBDIR += squidpurge
SUBDIR += squidstats
diff --git a/www/squidclamav/Makefile b/www/squidclamav/Makefile
new file mode 100644
index 000000000000..f886cdeee6da
--- /dev/null
+++ b/www/squidclamav/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: squidclamav
+# Date created: 15 August 2012
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD: ports/www/c-icap/Makefile,v 1.22 2011/09/23 22:25:54 amdmi3 Exp $
+#
+
+PORTNAME= squidclamav
+PORTVERSION= 6.8
+CATEGORIES= www security
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= Clamav c-icap service and redirector for Squid
+
+LICENSE= GPLv3
+
+LIB_DEPENDS+= icapapi:${PORTSDIR}/www/c-icap
+
+GNU_CONFIGURE= yes
+CFLAGS+= -DHAVE_STRNSTR
+
+MAN1= squidclamav.1
+
+CONFIGURE_ARGS+= --enable-static \
+ --sysconfdir="${PREFIX}/etc/c-icap" \
+ --with-c-icap=${LOCALBASE}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|CFGDIR=.*|CFGDIR="${PREFIX}/etc/c-icap"|g' \
+ ${WRKSRC}/configure.in ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/etc/squidclamav.conf|${PREFIX}/etc/c\\-icap/squidclamav.conf|g' \
+ ${WRKSRC}/doc/squidclamav.1
+
+.include <bsd.port.mk>
diff --git a/www/squidclamav/distinfo b/www/squidclamav/distinfo
new file mode 100644
index 000000000000..2a3ca06d60ea
--- /dev/null
+++ b/www/squidclamav/distinfo
@@ -0,0 +1,2 @@
+SHA256 (squidclamav-6.8.tar.gz) = 70dc1de6aa1a5cc705e336512699a0da530cf6f6e1130b261c5983ee89b34c49
+SIZE (squidclamav-6.8.tar.gz) = 840634
diff --git a/www/squidclamav/files/patch-etc-Makefile.in b/www/squidclamav/files/patch-etc-Makefile.in
new file mode 100644
index 000000000000..9843f4876126
--- /dev/null
+++ b/www/squidclamav/files/patch-etc-Makefile.in
@@ -0,0 +1,10 @@
+--- etc/Makefile.in.orig 2012-08-15 03:15:12.431509933 +0200
++++ etc/Makefile.in 2012-08-15 03:15:29.685506098 +0200
+@@ -338,6 +338,7 @@
+
+ install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(CFGINST)
++ $(INSTALL_DATA) $(srcdir)/squidclamav.conf $(DESTDIR)$(CFGINST)/squidclamav.conf.default
+ @if test -f "$(DESTDIR)$(CFGINST)/squidclamav.conf" ; then \
+ echo "$@ will not overwrite existing $(DESTDIR)$(CFGINST)/squidclamav.conf" ; \
+ else \
diff --git a/www/squidclamav/pkg-descr b/www/squidclamav/pkg-descr
new file mode 100644
index 000000000000..934cc4512350
--- /dev/null
+++ b/www/squidclamav/pkg-descr
@@ -0,0 +1,27 @@
+From the SquidClamav homepage:
+
+SquidClamav is an antivirus for Squid proxy based on the Awards winnings
+ClamAv anti-virus toolkit. Using it will help you securing your home or
+enterprise network web traffic. SquidClamav is the most efficient Squid
+Redirector and ICAP service antivirus tool for HTTP traffic available for
+free, it is written in C and can handle thousand of connections. The way
+to add more securing on your network for free is here.
+
+SquidClamav is build for speed and security in mind, it is first used
+and tested to secure a network with 2,500 and more users. It is also known
+to working fast with 15000+ users.
+
+SquidClamav since version 6.x works as an ICAP service through the c-icap
+server.
+
+With SquidClamav You have full control of what kind of HTTP stream must be
+scanned by Clamav antivirus, this control operate at 3 different levels:
+
+- At URL level, you can disable virus scanning for a set of web site,
+ filename extension or anything that can be matched in an URL.
+- At client side by disabling virus scan and other redirector call
+ to a set of username, source Ip addresses or computer DNS name.
+- At HTTP header level, where you can disable virus scanning following
+ the content type or file size.
+
+WWW: http://squidclamav.darold.net
diff --git a/www/squidclamav/pkg-plist b/www/squidclamav/pkg-plist
new file mode 100644
index 000000000000..062f22a9073e
--- /dev/null
+++ b/www/squidclamav/pkg-plist
@@ -0,0 +1,15 @@
+@unexec if cmp -s %D/etc/c-icap/squidclamav.conf %D/etc/c-icap/squidclamav.conf.default; then rm -f %D/etc/c-icap/squidclamav.conf; fi
+etc/c-icap/squidclamav.conf.default
+@exec [ -f %B/squidclamav.conf ] || cp %B/%f %B/squidclamav.conf
+%%DATADIR%%/README
+lib/c_icap/squidclamav.a
+lib/c_icap/squidclamav.la
+lib/c_icap/squidclamav.so
+libexec/squidclamav/clwarn.cgi
+libexec/squidclamav/clwarn.cgi.de_DE
+libexec/squidclamav/clwarn.cgi.en_EN
+libexec/squidclamav/clwarn.cgi.fr_FR
+libexec/squidclamav/clwarn.cgi.pt_BR
+libexec/squidclamav/clwarn.cgi.ru_RU
+@dirrm libexec/squidclamav
+@dirrm %%DATADIR%%