aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/pear-Services_Google/Makefile23
-rw-r--r--www/pear-Services_Google/distinfo3
-rw-r--r--www/pear-Services_Google/pkg-descr13
4 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 145cb984e051..8dcf44a8c213 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1018,6 +1018,7 @@
SUBDIR += pear-Services_Compete
SUBDIR += pear-Services_Delicious
SUBDIR += pear-Services_Digg
+ SUBDIR += pear-Services_Google
SUBDIR += pear-Services_SharedBook
SUBDIR += pear-Services_TinyURL
SUBDIR += pear-Services_W3C_CSSValidator
diff --git a/www/pear-Services_Google/Makefile b/www/pear-Services_Google/Makefile
new file mode 100644
index 000000000000..c35216074d34
--- /dev/null
+++ b/www/pear-Services_Google/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: pear-Services_Google
+# Date created: 13 April 2008
+# Whom: Wen heping <wenheping@gmail.com>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Services_Google
+PORTVERSION= 0.2.0
+CATEGORIES= www pear
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= PHP interface to access the Google SOAP Web APIs
+
+USE_PHP= soap
+CATEGORY= Services
+
+FILES= Google.php
+EXAMPLES= example1.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-Services_Google/distinfo b/www/pear-Services_Google/distinfo
new file mode 100644
index 000000000000..0e41d1c8ec87
--- /dev/null
+++ b/www/pear-Services_Google/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Services_Google-0.2.0.tgz) = 8960f656886605df9dff31faa7d8d10b
+SHA256 (PEAR/Services_Google-0.2.0.tgz) = de1ff3b101235ec1c1771c7781c142b8c41ce436b099b2e56815844afbc70e0c
+SIZE (PEAR/Services_Google-0.2.0.tgz) = 3213
diff --git a/www/pear-Services_Google/pkg-descr b/www/pear-Services_Google/pkg-descr
new file mode 100644
index 000000000000..378a4a0cfb05
--- /dev/null
+++ b/www/pear-Services_Google/pkg-descr
@@ -0,0 +1,13 @@
+pear-Services_Google is a pear class that
+provides access to the Google SOAP Web APIs.
+It allows easy access to the Google SOAP
+Web APIs for the search engine, spelling
+suggestions, and cache.
+
+Please note that as of December 5, 2006
+Google is no longer issuing new API keys
+for the SOAP search API, so this package
+is only for developers which has an API
+key already.
+
+WWW: http://pear.php.net/package/Services_Google/