aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/p5-Catalyst-Model-Xapian/Makefile2
-rw-r--r--www/xapian-omega/Makefile49
-rw-r--r--www/xapian-omega/distinfo4
-rw-r--r--www/xapian-omega/pkg-plist7
4 files changed, 33 insertions, 29 deletions
diff --git a/www/p5-Catalyst-Model-Xapian/Makefile b/www/p5-Catalyst-Model-Xapian/Makefile
index dc8f1b22817b..fcda3416bc04 100644
--- a/www/p5-Catalyst-Model-Xapian/Makefile
+++ b/www/p5-Catalyst-Model-Xapian/Makefile
@@ -19,7 +19,7 @@ COMMENT= Catalyst model for Search::Xapian
BUILD_DEPENDS= p5-Catalyst-Runtime>=5.30:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-Catalyst-Devel>=1.00:${PORTSDIR}/www/p5-Catalyst-Devel \
p5-Data-Page>=0:${PORTSDIR}/databases/p5-Data-Page \
- p5-Search-Xapian>=0.9.2.4:${PORTSDIR}/databases/p5-Search-Xapian
+ p5-Search-Xapian>=1.2.7.0:${PORTSDIR}/databases/p5-Search-Xapian
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/xapian-omega/Makefile b/www/xapian-omega/Makefile
index a54522061547..6cd21430e236 100644
--- a/www/xapian-omega/Makefile
+++ b/www/xapian-omega/Makefile
@@ -5,38 +5,43 @@
# $FreeBSD$
PORTNAME= xapian-omega
-PORTVERSION= 1.0.22
+PORTVERSION= 1.2.7
CATEGORIES= www
MASTER_SITES= http://oligarchy.co.uk/xapian/${PORTVERSION}/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= brix
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= CGI search application built on Xapian
-LIB_DEPENDS= xapian.21:${PORTSDIR}/databases/xapian-core
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
+ xapian.26:${PORTSDIR}/databases/xapian-core
LICENSE= GPLv2
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-USE_PERL5_RUN= yes
+
+OPTIONS= ICONV "Enable iconv character set conversion support" on
+
+CONFIGURE_ENV= PCRE_CONFIG=${LOCALBASE}/bin/pcre-config \
+ XAPIAN_CONFIG=${LOCALBASE}/bin/xapian-config
CPPFLAGS+= -I${LOCALBASE}/include
+GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
+USE_LDCONFIG= yes
+USE_PERL5= yes
MAN1= omindex.1 scriptindex.1
MORE_PORTDOCS= AUTHORS ChangeLog NEWS README TODO
-PORTDOCS= cgiparams.html omegascript.html overview.html \
- quickstart.html scriptindex.html termprefixes.html \
+PORTDOCS= cgiparams.html \
+ index.html \
+ omegascript.html \
+ overview.html \
+ quickstart.html \
+ scriptindex.html \
+ termprefixes.html \
${MORE_PORTDOCS}
PORTEXAMPLES= omega.conf
-OPTIONS= ICONV "Enable iconv character set conversion support" On
-
-PORTSCOUT= limit:^1\.0\.
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_ICONV)
USE_ICONV= yes
@@ -48,22 +53,20 @@ CONFIGURE_ARGS+= --without-iconv
post-patch:
@${REINPLACE_CMD} \
-e 's|^\(dist_sysconf_DATA\ =\ omega\.conf\)|#\1|' \
- -e "s|^\(pkglibbindir\)\ =.*/bin|\1\ =\ \$$(prefix)/${WWWDIR_REL}/cgi-bin|" \
+ -e 's|^\(pkglibbindir\)\ =.*/bin|\1\ =\ \$$(prefix)/${WWWDIR_REL}/cgi-bin|' \
${WRKSRC}/Makefile.in
.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} \
- -e 's|^\(SUBDIRS\ =\ \.\) docs|\1|' \
- ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^SUBDIRS = / s| docs||' ${WRKSRC}/Makefile.in
.endif
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${MORE_PORTDOCS:S@^@${WRKSRC}/@} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${MORE_PORTDOCS} ${DOCSDIR}/
.endif
.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${PORTEXAMPLES:S@^@${WRKSRC}/@} ${EXAMPLESDIR}
+ ${MKDIR} ${EXAMPLESDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/xapian-omega/distinfo b/www/xapian-omega/distinfo
index eb2550af5894..9a7863efa983 100644
--- a/www/xapian-omega/distinfo
+++ b/www/xapian-omega/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xapian-omega-1.0.22.tar.gz) = 99ccee86642fdbb0d1c97ffb065a4fc36541c5a39163d3540500377d14ef16c5
-SIZE (xapian-omega-1.0.22.tar.gz) = 515922
+SHA256 (xapian-omega-1.2.7.tar.gz) = 867497e77ea39cde079c0a18aab1106401f6dc8bf9b5e0087d23727db4032786
+SIZE (xapian-omega-1.2.7.tar.gz) = 608920
diff --git a/www/xapian-omega/pkg-plist b/www/xapian-omega/pkg-plist
index b05808b0fd9a..d01d78496707 100644
--- a/www/xapian-omega/pkg-plist
+++ b/www/xapian-omega/pkg-plist
@@ -3,9 +3,10 @@ bin/htdig2omega
bin/mbox2omega
bin/omindex
bin/scriptindex
-www/xapian-omega/cgi-bin/omega
share/omega/htdig2omega.script
share/omega/mbox2omega.script
-@dirrm www/xapian-omega/cgi-bin
-@dirrm www/xapian-omega
+%%WWWDIR%%/cgi-bin/omega
+%%WWWDIR%%/cgi-bin/outlookmsg2html
+@dirrm %%WWWDIR%%/cgi-bin
+@dirrm %%WWWDIR%%
@dirrm share/omega