aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-wikitemplates/Makefile28
-rw-r--r--www/trac-wikitemplates/distinfo3
-rw-r--r--www/trac-wikitemplates/pkg-descr4
-rw-r--r--www/trac-wikitemplates/pkg-plist1
5 files changed, 37 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 70ffd9d267f1..8919b3767d06 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1176,6 +1176,7 @@
SUBDIR += trac-webadmin
SUBDIR += trac-wikinotification
SUBDIR += trac-wikirename
+ SUBDIR += trac-wikitemplates
SUBDIR += trac-xmlrpc
SUBDIR += transproxy
SUBDIR += twhttpd
diff --git a/www/trac-wikitemplates/Makefile b/www/trac-wikitemplates/Makefile
new file mode 100644
index 000000000000..04e0ecb097a2
--- /dev/null
+++ b/www/trac-wikitemplates/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: trac-wikitemplates
+# Date created: May 18 2007
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wikitemplates
+PORTVERSION= 0.3.0p3
+CATEGORIES= www devel python
+MASTER_SITES= http://www.gerritbeine.de/download/trac/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION:S/p/rc/}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Templates for the Trac wiki
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac \
+ ${PYTHON_SITELIBDIR}/TracCtxtnavAdd-1.1_r1-py${_PYTHON_VERSION}.egg:${PORTSDIR}/www/trac-ctxtnavadd
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+NO_BUILD= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION:S/p/rc/} PYTHONVERSION=${_PYTHON_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/trac-wikitemplates/distinfo b/www/trac-wikitemplates/distinfo
new file mode 100644
index 000000000000..ada4d7f1d4e6
--- /dev/null
+++ b/www/trac-wikitemplates/distinfo
@@ -0,0 +1,3 @@
+MD5 (wikitemplatesplugin-0.3.0rc3.tar.gz) = 66dd9ef2adc967ff82b976b5e3419e2d
+SHA256 (wikitemplatesplugin-0.3.0rc3.tar.gz) = c6299de414f4c4d23d3e84f4724ee5a926380e26ab73576fed889b5a11974bae
+SIZE (wikitemplatesplugin-0.3.0rc3.tar.gz) = 46332
diff --git a/www/trac-wikitemplates/pkg-descr b/www/trac-wikitemplates/pkg-descr
new file mode 100644
index 000000000000..c75be7e210cf
--- /dev/null
+++ b/www/trac-wikitemplates/pkg-descr
@@ -0,0 +1,4 @@
+WikiTemplates is a Trac plugin. This plugin will provide you a way to include
+parts of other wiki pages, the templates, into our current wiki page.
+
+WWW: http://trac-hacks.org/wiki/WikiTemplatesPlugin
diff --git a/www/trac-wikitemplates/pkg-plist b/www/trac-wikitemplates/pkg-plist
new file mode 100644
index 000000000000..41ec57b14723
--- /dev/null
+++ b/www/trac-wikitemplates/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/TracWikiTemplates-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg