aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-Server-Simple-Mason/Makefile31
-rw-r--r--www/p5-HTTP-Server-Simple-Mason/distinfo2
-rw-r--r--www/p5-HTTP-Server-Simple-Mason/pkg-descr1
-rw-r--r--www/p5-HTTP-Server-Simple-Mason/pkg-plist4
5 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9aecf0c95c38..e4494ccf021a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -504,6 +504,7 @@
SUBDIR += p5-HTTP-Proxy
SUBDIR += p5-HTTP-Recorder
SUBDIR += p5-HTTP-Server-Simple
+ SUBDIR += p5-HTTP-Server-Simple-Mason
SUBDIR += p5-HTTP-Server-Simple-Static
SUBDIR += p5-HTTP-WebTest
SUBDIR += p5-HTTPD-Log-Filter
diff --git a/www/p5-HTTP-Server-Simple-Mason/Makefile b/www/p5-HTTP-Server-Simple-Mason/Makefile
new file mode 100644
index 000000000000..7217ba076319
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple-Mason/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: HTTP::Server::Simple::Mason
+# Date created: 28 April 2005
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Server-Simple-Mason
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= An abstract baseclass for a standalone mason server
+
+RUN_DEPENDS= ${SITE_PERL}/HTTP/Server/Simple.pm:${PORTSDIR}/www/p5-HTTP-Server-Simple \
+ ${SITE_PERL}/Apache/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE=yes
+
+MAN3= HTTP::Server::Simple::Mason.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6 or newer. Install lang/perl5 or lang/perl5.8, and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTTP-Server-Simple-Mason/distinfo b/www/p5-HTTP-Server-Simple-Mason/distinfo
new file mode 100644
index 000000000000..b51c1bdfcab6
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple-Mason/distinfo
@@ -0,0 +1,2 @@
+MD5 (HTTP-Server-Simple-Mason-0.03.tar.gz) = e2b981eea959bd45309c464a56823886
+SIZE (HTTP-Server-Simple-Mason-0.03.tar.gz) = 11170
diff --git a/www/p5-HTTP-Server-Simple-Mason/pkg-descr b/www/p5-HTTP-Server-Simple-Mason/pkg-descr
new file mode 100644
index 000000000000..d42a1fb22134
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple-Mason/pkg-descr
@@ -0,0 +1 @@
+An abstract baseclass for a standalone mason server.
diff --git a/www/p5-HTTP-Server-Simple-Mason/pkg-plist b/www/p5-HTTP-Server-Simple-Mason/pkg-plist
new file mode 100644
index 000000000000..37e8a7550654
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple-Mason/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/HTTP/Server/Simple/Mason.pm
+@unexec rmdir %D/%%SITE_PERL%%/HTTP/Server/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTTP/Server 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTTP 2>/dev/null || true