aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/apt-cacher-ng/Makefile2
-rw-r--r--www/choqok/Makefile2
-rw-r--r--www/cpr/Makefile2
-rw-r--r--www/cutelyst/Makefile2
-rw-r--r--www/davix/Makefile2
-rw-r--r--www/edbrowse/Makefile2
-rw-r--r--www/falkon/Makefile2
-rw-r--r--www/faup/Makefile2
-rw-r--r--www/hiawatha/Makefile2
-rw-r--r--www/kdewebdev-kde4/Makefile2
-rw-r--r--www/kf5-kdewebkit/Makefile2
-rw-r--r--www/kf5-khtml/Makefile2
-rw-r--r--www/kf5-kjs/Makefile2
-rw-r--r--www/kf5-kjsembed/Makefile2
-rw-r--r--www/libevhtp/Makefile2
-rw-r--r--www/libhpack/Makefile2
-rw-r--r--www/osrm-backend/Makefile2
-rw-r--r--www/otter-browser/Makefile2
-rw-r--r--www/plasma5-plasma-browser-integration/Makefile2
-rw-r--r--www/qhttpengine/Makefile2
-rw-r--r--www/qt5-webkit/Makefile2
-rw-r--r--www/rekonq/Makefile2
-rw-r--r--www/restbed/Makefile2
-rw-r--r--www/webkit2-gtk3/Makefile2
-rw-r--r--www/wt/Makefile2
-rw-r--r--www/xpi-u2f4moz/Makefile2
26 files changed, 26 insertions, 26 deletions
diff --git a/www/apt-cacher-ng/Makefile b/www/apt-cacher-ng/Makefile
index c80c4072e883..29a60129ee5c 100644
--- a/www/apt-cacher-ng/Makefile
+++ b/www/apt-cacher-ng/Makefile
@@ -14,7 +14,7 @@ LICENSE_NAME= Eduard Bloch license
LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USES= compiler:c++11-lang cmake:outsource ssl tar:xz
+USES= compiler:c++11-lang cmake ssl tar:xz
USE_RC_SUBR= apt_cacher_ng
CMAKE_ARGS= -DLIBDIR:PATH=${DATADIR} \
diff --git a/www/choqok/Makefile b/www/choqok/Makefile
index cea8bc8e910f..d3a9d405b51b 100644
--- a/www/choqok/Makefile
+++ b/www/choqok/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libqjson-qt5.so:devel/qjson@qt5 \
libqoauth-qt5.so:net/qoauth-qt5 \
libtelepathy-qt5.so:net-im/telepathy-qt@qt5
-USES= cmake:outsource compiler:c++11-lib gettext kde:5 pkgconfig qt:5 tar:xz
+USES= cmake compiler:c++11-lib gettext kde:5 pkgconfig qt:5 tar:xz
USE_KDE= attica auth bookmarks codecs completion config configwidgets \
coreaddons doctools ecm emoticons globalaccel guiaddons i18n \
itemviews jobwidgets kcmutils kdewebkit kio notifications \
diff --git a/www/cpr/Makefile b/www/cpr/Makefile
index d32c8279be1b..c9da8ae6ef54 100644
--- a/www/cpr/Makefile
+++ b/www/cpr/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= cmake:outsource
+USES= cmake
USE_GITHUB= yes
GH_ACCOUNT= whoshuu
GH_TUPLE= whoshuu:mongoose:df9f7a7:mongoose/opt/mongoose
diff --git a/www/cutelyst/Makefile b/www/cutelyst/Makefile
index e86038b4ba03..74a97e83e021 100644
--- a/www/cutelyst/Makefile
+++ b/www/cutelyst/Makefile
@@ -11,7 +11,7 @@ COMMENT= C++/Qt web framework
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource localbase qt:5
+USES= cmake localbase qt:5
USE_GITHUB= yes
USE_LDCONFIG= yes
USE_QT= qmake_build buildtools_build \
diff --git a/www/davix/Makefile b/www/davix/Makefile
index 566bda778e1a..634f9cc23956 100644
--- a/www/davix/Makefile
+++ b/www/davix/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libuuid.so:misc/e2fsprogs-libuuid
-USES= cmake:outsource compiler:c++11-lang gnome localbase:ldflags python:build shebangfix ssl
+USES= cmake compiler:c++11-lang gnome localbase:ldflags python:build shebangfix ssl
SHEBANG_GLOB= *.py
USE_GNOME= libxml2
USE_LDCONFIG= yes
diff --git a/www/edbrowse/Makefile b/www/edbrowse/Makefile
index 5719d81968b5..6fb532160b1a 100644
--- a/www/edbrowse/Makefile
+++ b/www/edbrowse/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
libtidy5.so:www/tidy-html5 \
libduktape.so:lang/duktape-lib
-USES= cmake compiler:c11 perl5 readline
+USES= cmake:insource compiler:c11 perl5 readline
USE_PERL5= build
USE_GITHUB= yes
diff --git a/www/falkon/Makefile b/www/falkon/Makefile
index b26c498048d0..b8464b353a0b 100644
--- a/www/falkon/Makefile
+++ b/www/falkon/Makefile
@@ -12,7 +12,7 @@ COMMENT= Web browser based on WebKit engine and Qt Framework
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource desktop-file-utils kde:5 qt:5 ssl tar:xz
+USES= cmake desktop-file-utils kde:5 qt:5 ssl tar:xz
USE_KDE= wallet
USE_QT= core dbus declarative gui location network printsupport \
sql webchannel webengine widgets x11extras \
diff --git a/www/faup/Makefile b/www/faup/Makefile
index 853a763a4866..45065ed9254e 100644
--- a/www/faup/Makefile
+++ b/www/faup/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= stricaud
-USES= cmake:outsource lua
+USES= cmake lua
USE_LDCONFIG= yes
PORTDOCS= *
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
index b4691b475621..77969105a320 100644
--- a/www/hiawatha/Makefile
+++ b/www/hiawatha/Makefile
@@ -13,7 +13,7 @@ COMMENT= Advanced and secure webserver for Unix
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake compiler:c11
+USES= cmake:insource compiler:c11
USE_RC_SUBR= hiawatha
CMAKE_ARGS= -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
diff --git a/www/kdewebdev-kde4/Makefile b/www/kdewebdev-kde4/Makefile
index d1ccf303ec79..22a434ec7997 100644
--- a/www/kdewebdev-kde4/Makefile
+++ b/www/kdewebdev-kde4/Makefile
@@ -16,7 +16,7 @@ EXPIRATION_DATE= 2018-12-31
LIB_DEPENDS= libtidy.so:www/tidy-lib \
libboost_thread.so:devel/boost-libs
-USES= cmake:outsource kde:4 qt:4 tar:xz
+USES= cmake kde:4 qt:4 tar:xz
USE_GNOME= libxml2 libxslt
USE_KDE= kdelibs pimlibs automoc4
USE_QT= dbus porting_build \
diff --git a/www/kf5-kdewebkit/Makefile b/www/kf5-kdewebkit/Makefile
index 04e75ba8f69a..b6398400679d 100644
--- a/www/kf5-kdewebkit/Makefile
+++ b/www/kf5-kdewebkit/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= www kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
COMMENT= KF5 library providing integration of QtWebKit
-USES= cmake:outsource compiler:c++11-lib gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons \
ecm i18n jobwidgets kio parts service sonnet textwidgets \
wallet widgetsaddons xmlgui
diff --git a/www/kf5-khtml/Makefile b/www/kf5-khtml/Makefile
index 39218041da4b..4b1dc7ede6a1 100644
--- a/www/kf5-khtml/Makefile
+++ b/www/kf5-khtml/Makefile
@@ -10,7 +10,7 @@ COMMENT= KF5 KTHML rendering engine
LIB_DEPENDS= libgif.so:graphics/giflib \
libpng.so:graphics/png
-USES= cmake:outsource compiler:c++11-lib gettext gperf jpeg kde:5 \
+USES= cmake compiler:c++11-lib gettext gperf jpeg kde:5 \
qt:5 tar:xz
USE_KDE= archive auth bookmarks codecs completion config \
configwidgets coreaddons ecm globalaccel i18n iconthemes \
diff --git a/www/kf5-kjs/Makefile b/www/kf5-kjs/Makefile
index 11245a37a3af..fbbd06e68c7d 100644
--- a/www/kf5-kjs/Makefile
+++ b/www/kf5-kjs/Makefile
@@ -9,7 +9,7 @@ COMMENT= KF5 library providing an ECMAScript interpreter
LIB_DEPENDS= libpcre.so:devel/pcre
-USES= cmake:outsource compiler:c++11-lib kde:5 pkgconfig qt:5 tar:xz
+USES= cmake compiler:c++11-lib kde:5 pkgconfig qt:5 tar:xz
USE_KDE= ecm doctools
USE_QT= buildtools_build core qmake_build
diff --git a/www/kf5-kjsembed/Makefile b/www/kf5-kjsembed/Makefile
index 58c0d278c239..e65bc68113cc 100644
--- a/www/kf5-kjsembed/Makefile
+++ b/www/kf5-kjsembed/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= www kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
COMMENT= KF5 library for binding JavaScript objects to QObjects
-USES= cmake:outsource compiler:c++11-lib gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
USE_KDE= archive doctools ecm i18n js
USE_QT= buildtools_build core gui qmake_build svg \
uiplugin uitools widgets xml
diff --git a/www/libevhtp/Makefile b/www/libevhtp/Makefile
index 47e7cf6d5f2a..e9ac11f4f843 100644
--- a/www/libevhtp/Makefile
+++ b/www/libevhtp/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libevent.so:devel/libevent
-USES= cmake:outsource
+USES= cmake
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= criticalstack
diff --git a/www/libhpack/Makefile b/www/libhpack/Makefile
index fb49f5071007..7b6a18771d16 100644
--- a/www/libhpack/Makefile
+++ b/www/libhpack/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= libcheck.so:devel/check
CMAKE_OFF= BUILD_DOCS BUILD_TESTS ENABLE_GCOV USE_VALGRIND
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
-USES= cmake pathfix pkgconfig python:2.7,build shebangfix
+USES= cmake:insource pathfix pkgconfig python:2.7,build shebangfix
GH_ACCOUNT= alobbs
GH_TAGNAME= b0ade19
diff --git a/www/osrm-backend/Makefile b/www/osrm-backend/Makefile
index 9ffffed70e58..0fa476f4541e 100644
--- a/www/osrm-backend/Makefile
+++ b/www/osrm-backend/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS= libtbb.so:devel/tbb \
libboost_regex.so:devel/boost-libs \
libexpat.so:textproc/expat2
-USES= cmake:outsource lua:53 compiler:c++14-lang
+USES= cmake lua:53 compiler:c++14-lang
USE_GITHUB= yes
GH_ACCOUNT= Project-OSRM
USE_LDCONFIG= yes
diff --git a/www/otter-browser/Makefile b/www/otter-browser/Makefile
index 95a0399373f6..581747872846 100644
--- a/www/otter-browser/Makefile
+++ b/www/otter-browser/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
-USES= cmake:outsource compiler:c++11-lib desktop-file-utils qt:5
+USES= cmake compiler:c++11-lib desktop-file-utils qt:5
USE_QT= concurrent core dbus declarative gui multimedia network printsupport \
script sql sql-sqlite3 svg widgets xmlpatterns \
buildtools_build qmake_build
diff --git a/www/plasma5-plasma-browser-integration/Makefile b/www/plasma5-plasma-browser-integration/Makefile
index bb0be9e31b57..ee33b9309fc9 100644
--- a/www/plasma5-plasma-browser-integration/Makefile
+++ b/www/plasma5-plasma-browser-integration/Makefile
@@ -9,7 +9,7 @@ PKGNAMEPREFIX= plasma5- # this port is not yet using CATEGORIES=kde-plasma
MAINTAINER= kde@FreeBSD.org
COMMENT= Plasma5 components to integrate browsers into the desktop
-USES= compiler:c++11-lang cmake:outsource kde:5 qt:5
+USES= compiler:c++11-lang cmake kde:5 qt:5
USE_KDE= activities config coreaddons i18n kio notifications package \
plasma-framework runner service windowsystem
USE_QT= core dbus gui widgets \
diff --git a/www/qhttpengine/Makefile b/www/qhttpengine/Makefile
index b072b4b0ba10..db537a1872aa 100644
--- a/www/qhttpengine/Makefile
+++ b/www/qhttpengine/Makefile
@@ -12,7 +12,7 @@ COMMENT= HTTP server for Qt applications
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= cmake:outsource compiler:c++11-lang qt:5
+USES= cmake compiler:c++11-lang qt:5
USE_GITHUB= yes
GH_ACCOUNT= nitroshare
USE_QT= core network buildtools_build qmake_build
diff --git a/www/qt5-webkit/Makefile b/www/qt5-webkit/Makefile
index 8dafefd78580..6f77fd101f9a 100644
--- a/www/qt5-webkit/Makefile
+++ b/www/qt5-webkit/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libpng.so:graphics/png \
libwebp.so:graphics/webp
-USES= bison cmake:outsource compiler:c++11-lang gperf jpeg \
+USES= bison cmake compiler:c++11-lang gperf jpeg \
pathfix perl5 pkgconfig python:2.7,build qt:5 sqlite:3 \
tar:xz
USE_GNOME= glib20 libxml2 libxslt
diff --git a/www/rekonq/Makefile b/www/rekonq/Makefile
index 735d4872d958..c55255bb73af 100644
--- a/www/rekonq/Makefile
+++ b/www/rekonq/Makefile
@@ -17,7 +17,7 @@ EXPIRATION_DATE= 2018-12-31
LICENSE_FILE_GPLv3+ = ${WRKSRC}/COPYING
LICENSE_FILE_GFDL= ${WRKSRC}/COPYING.DOC
-USES= cmake:outsource gettext kde:4 qt:4 tar:xz
+USES= cmake gettext kde:4 qt:4 tar:xz
USE_KDE= kdelibs automoc4
USE_QT= script webkit \
moc_build qmake_build rcc_build uic_build
diff --git a/www/restbed/Makefile b/www/restbed/Makefile
index 53d8d4e3baf3..ad217961003f 100644
--- a/www/restbed/Makefile
+++ b/www/restbed/Makefile
@@ -11,7 +11,7 @@ COMMENT= Asynchronous RESTful functionality to C++11 applications
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake:outsource compiler:c++11-lib ssl
+USES= cmake compiler:c++11-lib ssl
USE_GITHUB= yes
GH_ACCOUNT= Corvusoft
GH_TUPLE= Corvusoft:asio-dependency:f5c5708:a/dependency/asio \
diff --git a/www/webkit2-gtk3/Makefile b/www/webkit2-gtk3/Makefile
index 3d20c168b614..4f482750c214 100644
--- a/www/webkit2-gtk3/Makefile
+++ b/www/webkit2-gtk3/Makefile
@@ -33,7 +33,7 @@ LIB_DEPENDS= libenchant-2.so:textproc/enchant2 \
PORTSCOUT= limitw:1,even
-USES= bison cmake:outsource compiler:c++14-lang gettext gl gnome gperf \
+USES= bison cmake compiler:c++14-lang gettext gl gnome gperf \
jpeg localbase:ldflags perl5 pkgconfig python:2.7,build \
sqlite tar:xz
USE_GNOME= cairo gdkpixbuf2 gtk30 introspection:build libxml2 libxslt
diff --git a/www/wt/Makefile b/www/wt/Makefile
index add15fe7bb6d..1e4b6d283d44 100644
--- a/www/wt/Makefile
+++ b/www/wt/Makefile
@@ -25,7 +25,7 @@ USE_GITHUB= yes
GH_ACCOUNT= kdeforche
USE_LDCONFIG= yes
USE_XORG+=x11
-USES= cmake:outsource pkgconfig ssl
+USES= cmake pkgconfig ssl
CMAKE_ARGS+= -DCONFIGDIR:STRING=${LOCALBASE}/etc/wt \
-DGM_PREFIX:STRING=${LOCALBASE} \
-DPNG_PREFIX:STRING=${LOCALBASE} \
diff --git a/www/xpi-u2f4moz/Makefile b/www/xpi-u2f4moz/Makefile
index 0fe0ea746eef..c6544d59bd7e 100644
--- a/www/xpi-u2f4moz/Makefile
+++ b/www/xpi-u2f4moz/Makefile
@@ -22,7 +22,7 @@ PLIST_SUB= SYSTEM_PROCESSOR=${SYSTEM_PROCESSOR}
SYSTEM_PROCESSOR= x86
USE_GITHUB= yes
-USES= cmake iconv pkgconfig
+USES= cmake:insource iconv pkgconfig
XPI_DIR= lib/xpi
XPI_ID= u2f4moz@prefiks.org