aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile4
-rw-r--r--www/epiphany/Makefile12
-rw-r--r--www/galeon/Makefile14
-rw-r--r--www/galeon2/Makefile12
-rw-r--r--www/mozilla-bonobo/Makefile12
-rw-r--r--www/mozilla-devel-gtk1/Makefile14
-rw-r--r--www/mozilla-devel-gtk2/Makefile19
-rw-r--r--www/mozilla-devel/Makefile14
-rw-r--r--www/mozilla-devel/pkg-descr3
-rw-r--r--www/mozilla-devel/pkg-descr.gtk1 (renamed from www/seamonkey/pkg-descr.gtk2)4
-rw-r--r--www/mozilla-gtk1/Makefile12
-rw-r--r--www/mozilla-gtk2/Makefile19
-rw-r--r--www/mozilla/Makefile14
-rw-r--r--www/mozilla/pkg-descr3
-rw-r--r--www/mozilla/pkg-descr.gtk1 (renamed from www/mozilla/pkg-descr.gtk2)4
-rw-r--r--www/mplayer-plugin/Makefile14
-rw-r--r--www/seamonkey/Makefile14
-rw-r--r--www/seamonkey/pkg-descr3
-rw-r--r--www/seamonkey/pkg-descr.gtk1 (renamed from www/mozilla-devel/pkg-descr.gtk2)4
-rw-r--r--www/seamonkey2/Makefile14
-rw-r--r--www/seamonkey2/pkg-descr3
-rw-r--r--www/seamonkey2/pkg-descr.gtk1 (renamed from www/seamonkey2/pkg-descr.gtk2)4
22 files changed, 93 insertions, 123 deletions
diff --git a/www/Makefile b/www/Makefile
index 037f1c0db34f..e456799ddd98 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -285,8 +285,8 @@
SUBDIR += mozilla
SUBDIR += mozilla-bonobo
SUBDIR += mozilla-devel
- SUBDIR += mozilla-devel-gtk2
- SUBDIR += mozilla-gtk2
+ SUBDIR += mozilla-devel-gtk1
+ SUBDIR += mozilla-gtk1
SUBDIR += mplayer-plugin
SUBDIR += nd
SUBDIR += neon
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index 1d08cc40b7da..7254d14909b7 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -21,19 +21,19 @@ RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/
MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.6"
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.else
-.if ${WITH_MOZILLA}=="mozilla-devel-gtk2"
+.if ${WITH_MOZILLA}=="mozilla-devel-gtk2" || ${WITH_MOZILLA}=="mozilla-devel"
MOZILLA= ${WITH_MOZILLA}
HEADERS_SUFX= -devel
MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.6b"
.else
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.endif
.endif
@@ -76,10 +76,10 @@ CONFIGURE_ARGS+= --disable-werror
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} " By default epiphany uses www/mozilla-gtk2 for html rendering, but you can"
+ @${ECHO_MSG} " By default epiphany uses www/mozilla for html rendering, but you can"
@${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG}
- @${ECHO_MSG} " mozilla-devel-gtk2 "
+ @${ECHO_MSG} " mozilla-devel "
@${ECHO_MSG} ""
post-extract:
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index b216fa9874d0..57bb356e8e72 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -22,15 +22,15 @@ RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/libgtkembedmoz.so:${PORTSDIR}/www/${MOZIL
MOZ_CONFIGURE_ARGS=--with-mozilla-snapshot="trunk"
.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla
+MOZILLA= mozilla-gtk1
HEADERS_SUFX=
.else
-.if ${WITH_MOZILLA}=="mozilla-devel"
+.if ${WITH_MOZILLA}=="mozilla-devel-gtk1"
MOZILLA= ${WITH_MOZILLA}
-HEADERS_SUFX= -devel
+HEADERS_SUFX= -devel-gtk1
MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.6b"
.else
-MOZILLA= mozilla
+MOZILLA= mozilla-gtk1
HEADERS_SUFX=
.endif
.endif
@@ -62,10 +62,10 @@ CONFIGURE_ARGS+= --disable-werror
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} " By default the port uses www/mozilla for html rendering, but you can change"
- @${ECHO_MSG} " this by defining WITH_MOZILLA to one of the following values:"
+ @${ECHO_MSG} " By default the port uses www/mozilla-gtk1 for html rendering, but you can"
+ @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG}
- @${ECHO_MSG} " mozilla-devel "
+ @${ECHO_MSG} " mozilla-devel-gtk1 "
@${ECHO_MSG} ""
post-patch:
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index b442e1f9175e..aebabc6ee5ab 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -21,19 +21,19 @@ RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/
MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.6"
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.else
-.if ${WITH_MOZILLA}=="mozilla-devel-gtk2"
+.if ${WITH_MOZILLA}=="mozilla-devel" || ${WITH_MOZILLA}=="mozilla-devel-gtk2"
MOZILLA= ${WITH_MOZILLA}
HEADERS_SUFX= -devel
MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.6b"
.else
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.endif
.endif
@@ -72,10 +72,10 @@ CONFIGURE_ARGS+= --disable-werror
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} " By default the port uses www/mozilla-gtk2 for html rendering, but you can"
+ @${ECHO_MSG} " By default the port uses www/mozilla for html rendering, but you can"
@${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG}
- @${ECHO_MSG} " mozilla-devel-gtk2 "
+ @${ECHO_MSG} " mozilla-devel "
@${ECHO_MSG} ""
post-patch:
diff --git a/www/mozilla-bonobo/Makefile b/www/mozilla-bonobo/Makefile
index 882e6cee2005..38978adabec5 100644
--- a/www/mozilla-bonobo/Makefile
+++ b/www/mozilla-bonobo/Makefile
@@ -18,18 +18,18 @@ COMMENT= A Netscape/Mozilla plugin using Bonobo controls to display files
BUILD_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.else
-.if ${WITH_MOZILLA}=="mozilla-devel-gtk2"
+.if ${WITH_MOZILLA}=="mozilla-devel" || ${WITH_MOZILLA}=="mozilla-devel-gtk2"
MOZILLA= ${WITH_MOZILLA}
HEADERS_SUFX= -devel
.else
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.endif
.endif
@@ -44,10 +44,10 @@ CONFIGURE_ARGS= --with-plugin-install-dir="${PREFIX}/lib/browser_plugins" \
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} " By default mozilla-bonobo uses www/mozilla-gtk2 for html rendering, but you can"
+ @${ECHO_MSG} " By default mozilla-bonobo uses www/mozilla for html rendering, but you can"
@${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG} ""
- @${ECHO_MSG} " mozilla-devel-gtk2 "
+ @${ECHO_MSG} " mozilla-devel "
@${ECHO_MSG} ""
post-patch:
diff --git a/www/mozilla-devel-gtk1/Makefile b/www/mozilla-devel-gtk1/Makefile
index adf5a2a10424..705c9bfebc08 100644
--- a/www/mozilla-devel-gtk1/Makefile
+++ b/www/mozilla-devel-gtk1/Makefile
@@ -1,19 +1,17 @@
-# New ports collection makefile for: mozilla-devel-gtk2
-# Date created: 17 November 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+# New ports collection makefile for: mozilla-devel-gtk1
+# Date created: 17 February 2004
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= mozilla
-PORTREVISION= 1
-PORTEPOCH= 0
CATEGORIES= www
MASTERDIR= ${.CURDIR}/../mozilla-devel
-DESCR= ${PKGDIR}/pkg-descr.gtk2
+DESCR= ${PKGDIR}/pkg-descr.gtk1
-WITH_GTK2= yes
-MOZILLA= mozilla-devel-gtk2
+WITH_GTK1= yes
+MOZILLA= mozilla-devel-gtk1
.include "${MASTERDIR}/Makefile"
diff --git a/www/mozilla-devel-gtk2/Makefile b/www/mozilla-devel-gtk2/Makefile
deleted file mode 100644
index adf5a2a10424..000000000000
--- a/www/mozilla-devel-gtk2/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-# New ports collection makefile for: mozilla-devel-gtk2
-# Date created: 17 November 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= mozilla
-PORTREVISION= 1
-PORTEPOCH= 0
-CATEGORIES= www
-
-MASTERDIR= ${.CURDIR}/../mozilla-devel
-DESCR= ${PKGDIR}/pkg-descr.gtk2
-
-WITH_GTK2= yes
-MOZILLA= mozilla-devel-gtk2
-
-.include "${MASTERDIR}/Makefile"
diff --git a/www/mozilla-devel/Makefile b/www/mozilla-devel/Makefile
index 0db3a4b9eeb2..3ece92d1b925 100644
--- a/www/mozilla-devel/Makefile
+++ b/www/mozilla-devel/Makefile
@@ -35,11 +35,11 @@ IGNORE= "Main port has been upgraded to 1.6"
MOZILLA?= mozilla-devel
MOZ_SUFX= -devel
-.if defined(WITH_GTK2)
-PKGNAMESUFFIX= -gtk2
-USE_GNOME= gtk20 libidl
-.else
+.if defined(WITH_GTK1)
+PKGNAMESUFFIX= -gtk1
USE_GNOME= gtk12 orbit
+.else
+USE_GNOME= gtk20 libidl
.endif
.if !defined(WITHOUT_XFT)
@@ -140,10 +140,10 @@ CONFIGURE_ARGS+= --enable-calendar
CONFIGURE_ARGS+= --disable-composer
.endif
-.if defined(WITH_GTK2)
-CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
-.else
+.if defined(WITH_GTK1)
CONFIGURE_ARGS+= --enable-default-toolkit=gtk
+.else
+CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
.endif
.if !defined(WITHOUT_XFT)
diff --git a/www/mozilla-devel/pkg-descr b/www/mozilla-devel/pkg-descr
index fe21e2f4102c..10b9ea56ea93 100644
--- a/www/mozilla-devel/pkg-descr
+++ b/www/mozilla-devel/pkg-descr
@@ -6,4 +6,7 @@ and Java with the use of the FreeBSD native Java plug-in.
This is the latest bleeding edge release. Beware that you'll probably find
bugs here, so if you value stability, try www/mozilla or www/mozilla-vendor.
+This version has been built with GTK+-2 bindings for use with applications
+such as Galeon 2.
+
WWW: http://www.mozilla.org/
diff --git a/www/seamonkey/pkg-descr.gtk2 b/www/mozilla-devel/pkg-descr.gtk1
index 10b9ea56ea93..ba0062b77d01 100644
--- a/www/seamonkey/pkg-descr.gtk2
+++ b/www/mozilla-devel/pkg-descr.gtk1
@@ -6,7 +6,7 @@ and Java with the use of the FreeBSD native Java plug-in.
This is the latest bleeding edge release. Beware that you'll probably find
bugs here, so if you value stability, try www/mozilla or www/mozilla-vendor.
-This version has been built with GTK+-2 bindings for use with applications
-such as Galeon 2.
+This version has been built with GTK+-1 bindings for use with older
+applications such as Galeon 1.
WWW: http://www.mozilla.org/
diff --git a/www/mozilla-gtk1/Makefile b/www/mozilla-gtk1/Makefile
index 5cb4b389199d..0f0a8a3b5c1a 100644
--- a/www/mozilla-gtk1/Makefile
+++ b/www/mozilla-gtk1/Makefile
@@ -1,19 +1,17 @@
-# New ports collection makefile for: mozilla-devel-gtk2
-# Date created: 17 November 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+# New ports collection makefile for: mozilla-devel-gtk1
+# Date created: 17 February 2004
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= mozilla
-PORTREVISION= 2
-PORTEPOCH= 0
CATEGORIES= www
MASTERDIR= ${.CURDIR}/../mozilla
-DESCR= ${PKGDIR}/pkg-descr.gtk2
+DESCR= ${PKGDIR}/pkg-descr.gtk1
WITH_GTK2= yes
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla-gtk1
.include "${MASTERDIR}/Makefile"
diff --git a/www/mozilla-gtk2/Makefile b/www/mozilla-gtk2/Makefile
deleted file mode 100644
index 5cb4b389199d..000000000000
--- a/www/mozilla-gtk2/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-# New ports collection makefile for: mozilla-devel-gtk2
-# Date created: 17 November 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= mozilla
-PORTREVISION= 2
-PORTEPOCH= 0
-CATEGORIES= www
-
-MASTERDIR= ${.CURDIR}/../mozilla
-DESCR= ${PKGDIR}/pkg-descr.gtk2
-
-WITH_GTK2= yes
-MOZILLA= mozilla-gtk2
-
-.include "${MASTERDIR}/Makefile"
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index b7d2deda463d..63b38a9403a2 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -32,11 +32,11 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MOZILLA?= mozilla
-.if defined(WITH_GTK2)
-PKGNAMESUFFIX= -gtk2
-USE_GNOME= gtk20 libidl
-.else
+.if defined(WITH_GTK1)
+PKGNAMESUFFIX= -gtk1
USE_GNOME= gtk12 orbit
+.else
+USE_GNOME= gtk20 libidl
.endif
.if !defined(WITHOUT_XFT)
@@ -136,10 +136,10 @@ CONFIGURE_ARGS+= --enable-calendar
CONFIGURE_ARGS+= --disable-composer
.endif
-.if defined(WITH_GTK2)
-CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
-.else
+.if defined(WITH_GTK1)
CONFIGURE_ARGS+= --enable-default-toolkit=gtk
+.else
+CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
.endif
.if !defined(WITHOUT_XFT)
diff --git a/www/mozilla/pkg-descr b/www/mozilla/pkg-descr
index 37a7a64039b1..d91ac6c1d832 100644
--- a/www/mozilla/pkg-descr
+++ b/www/mozilla/pkg-descr
@@ -7,4 +7,7 @@ This is the latest release of the Mozilla browser. It contains all the
bugfixes and security enhancements from the mozilla port as well as
new new features.
+This version has been built with GTK+-2 bindings for use with applications
+such as Galeon 2.
+
WWW: http://www.mozilla.org/
diff --git a/www/mozilla/pkg-descr.gtk2 b/www/mozilla/pkg-descr.gtk1
index d91ac6c1d832..25311e1399fc 100644
--- a/www/mozilla/pkg-descr.gtk2
+++ b/www/mozilla/pkg-descr.gtk1
@@ -7,7 +7,7 @@ This is the latest release of the Mozilla browser. It contains all the
bugfixes and security enhancements from the mozilla port as well as
new new features.
-This version has been built with GTK+-2 bindings for use with applications
-such as Galeon 2.
+This version has been built with GTK+-1 bindings for use with older
+applications such as Galeon 1.
WWW: http://www.mozilla.org/
diff --git a/www/mplayer-plugin/Makefile b/www/mplayer-plugin/Makefile
index 72159f8a83e5..a32caeb3f818 100644
--- a/www/mplayer-plugin/Makefile
+++ b/www/mplayer-plugin/Makefile
@@ -31,7 +31,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LDFLAGS="-L${X11BASE}/lib"
.if !defined(WITH_MOZILLA)
-HEADERS_SUFX= -gtk2
+HEADERS_SUFX=
.else
.if ${WITH_MOZILLA}=="mozilla"
HEADERS_SUFX=
@@ -39,10 +39,10 @@ HEADERS_SUFX=
.if ${WITH_MOZILLA}=="mozilla-devel"
HEADERS_SUFX= -devel
.else
-.if ${WITH_MOZILLA}=="mozilla-devel-gtk"
-HEADERS_SUFX= -devel-gtk2
+.if ${WITH_MOZILLA}=="mozilla-devel-gtk1"
+HEADERS_SUFX= -devel-gtk1
.else
-HEADERS_SUFX= -gtk2
+HEADERS_SUFX= -gtk1
.endif
.endif
.endif
@@ -50,12 +50,12 @@ HEADERS_SUFX= -gtk2
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} " By default this port uses www/mozilla-gtk2 for Gecko support, but you can"
+ @${ECHO_MSG} " By default this port uses www/mozilla for Gecko support, but you can"
@${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG}
- @${ECHO_MSG} " mozilla "
@${ECHO_MSG} " mozilla-devel "
- @${ECHO_MSG} " mozilla-devel-gtk2 "
+ @${ECHO_MSG} " mozilla-gtk1 "
+ @${ECHO_MSG} " mozilla-devel-gtk1 "
@${ECHO_MSG} ""
post-patch:
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 0db3a4b9eeb2..3ece92d1b925 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -35,11 +35,11 @@ IGNORE= "Main port has been upgraded to 1.6"
MOZILLA?= mozilla-devel
MOZ_SUFX= -devel
-.if defined(WITH_GTK2)
-PKGNAMESUFFIX= -gtk2
-USE_GNOME= gtk20 libidl
-.else
+.if defined(WITH_GTK1)
+PKGNAMESUFFIX= -gtk1
USE_GNOME= gtk12 orbit
+.else
+USE_GNOME= gtk20 libidl
.endif
.if !defined(WITHOUT_XFT)
@@ -140,10 +140,10 @@ CONFIGURE_ARGS+= --enable-calendar
CONFIGURE_ARGS+= --disable-composer
.endif
-.if defined(WITH_GTK2)
-CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
-.else
+.if defined(WITH_GTK1)
CONFIGURE_ARGS+= --enable-default-toolkit=gtk
+.else
+CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
.endif
.if !defined(WITHOUT_XFT)
diff --git a/www/seamonkey/pkg-descr b/www/seamonkey/pkg-descr
index fe21e2f4102c..10b9ea56ea93 100644
--- a/www/seamonkey/pkg-descr
+++ b/www/seamonkey/pkg-descr
@@ -6,4 +6,7 @@ and Java with the use of the FreeBSD native Java plug-in.
This is the latest bleeding edge release. Beware that you'll probably find
bugs here, so if you value stability, try www/mozilla or www/mozilla-vendor.
+This version has been built with GTK+-2 bindings for use with applications
+such as Galeon 2.
+
WWW: http://www.mozilla.org/
diff --git a/www/mozilla-devel/pkg-descr.gtk2 b/www/seamonkey/pkg-descr.gtk1
index 10b9ea56ea93..ba0062b77d01 100644
--- a/www/mozilla-devel/pkg-descr.gtk2
+++ b/www/seamonkey/pkg-descr.gtk1
@@ -6,7 +6,7 @@ and Java with the use of the FreeBSD native Java plug-in.
This is the latest bleeding edge release. Beware that you'll probably find
bugs here, so if you value stability, try www/mozilla or www/mozilla-vendor.
-This version has been built with GTK+-2 bindings for use with applications
-such as Galeon 2.
+This version has been built with GTK+-1 bindings for use with older
+applications such as Galeon 1.
WWW: http://www.mozilla.org/
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 0db3a4b9eeb2..3ece92d1b925 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -35,11 +35,11 @@ IGNORE= "Main port has been upgraded to 1.6"
MOZILLA?= mozilla-devel
MOZ_SUFX= -devel
-.if defined(WITH_GTK2)
-PKGNAMESUFFIX= -gtk2
-USE_GNOME= gtk20 libidl
-.else
+.if defined(WITH_GTK1)
+PKGNAMESUFFIX= -gtk1
USE_GNOME= gtk12 orbit
+.else
+USE_GNOME= gtk20 libidl
.endif
.if !defined(WITHOUT_XFT)
@@ -140,10 +140,10 @@ CONFIGURE_ARGS+= --enable-calendar
CONFIGURE_ARGS+= --disable-composer
.endif
-.if defined(WITH_GTK2)
-CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
-.else
+.if defined(WITH_GTK1)
CONFIGURE_ARGS+= --enable-default-toolkit=gtk
+.else
+CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
.endif
.if !defined(WITHOUT_XFT)
diff --git a/www/seamonkey2/pkg-descr b/www/seamonkey2/pkg-descr
index fe21e2f4102c..10b9ea56ea93 100644
--- a/www/seamonkey2/pkg-descr
+++ b/www/seamonkey2/pkg-descr
@@ -6,4 +6,7 @@ and Java with the use of the FreeBSD native Java plug-in.
This is the latest bleeding edge release. Beware that you'll probably find
bugs here, so if you value stability, try www/mozilla or www/mozilla-vendor.
+This version has been built with GTK+-2 bindings for use with applications
+such as Galeon 2.
+
WWW: http://www.mozilla.org/
diff --git a/www/seamonkey2/pkg-descr.gtk2 b/www/seamonkey2/pkg-descr.gtk1
index 10b9ea56ea93..ba0062b77d01 100644
--- a/www/seamonkey2/pkg-descr.gtk2
+++ b/www/seamonkey2/pkg-descr.gtk1
@@ -6,7 +6,7 @@ and Java with the use of the FreeBSD native Java plug-in.
This is the latest bleeding edge release. Beware that you'll probably find
bugs here, so if you value stability, try www/mozilla or www/mozilla-vendor.
-This version has been built with GTK+-2 bindings for use with applications
-such as Galeon 2.
+This version has been built with GTK+-1 bindings for use with older
+applications such as Galeon 1.
WWW: http://www.mozilla.org/