aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-requests-oauth-hook/Makefile25
-rw-r--r--www/py-requests-oauth-hook/distinfo2
-rw-r--r--www/py-requests-oauth-hook/pkg-descr8
-rw-r--r--www/py-requests-oauth-hook/pkg-plist25
5 files changed, 61 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ac93cc0248b5..1e3814d2cd8c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1536,6 +1536,7 @@
SUBDIR += py-qt4-webkit
SUBDIR += py-recaptcha
SUBDIR += py-requests
+ SUBDIR += py-requests-oauth-hook
SUBDIR += py-restclient
SUBDIR += py-routes
SUBDIR += py-rssdler
diff --git a/www/py-requests-oauth-hook/Makefile b/www/py-requests-oauth-hook/Makefile
new file mode 100644
index 000000000000..bf7f0be00be6
--- /dev/null
+++ b/www/py-requests-oauth-hook/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-requests-oauth-hook
+# Date created: 2011-10-31
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= requests-oauth-hook
+PORTVERSION= 0.1.3
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= This is an OAuth hook for py-requests
+
+LICENSE= BSD
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}oauth2>0:${PORTSDIR}/net/py-oauth2
+
+USE_PYTHON= 2.6+
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>
diff --git a/www/py-requests-oauth-hook/distinfo b/www/py-requests-oauth-hook/distinfo
new file mode 100644
index 000000000000..66f51ea22709
--- /dev/null
+++ b/www/py-requests-oauth-hook/distinfo
@@ -0,0 +1,2 @@
+SHA256 (requests-oauth-hook-0.1.3.tar.gz) = 6ea2bd984d39c8cfd9d3169f59b76e1630988956c09e4f310bbf89ad406ad192
+SIZE (requests-oauth-hook-0.1.3.tar.gz) = 7222
diff --git a/www/py-requests-oauth-hook/pkg-descr b/www/py-requests-oauth-hook/pkg-descr
new file mode 100644
index 000000000000..5f27f844b4bd
--- /dev/null
+++ b/www/py-requests-oauth-hook/pkg-descr
@@ -0,0 +1,8 @@
+This is a hook for python-requests great python HTTP library, that
+makes python-requests support Open Authentication version 1.0.
+
+This hook is based on python-oauth2 and uses portions of its code
+at the moment, kudos to the authors and contributors for doing a
+huge effort in providing OAuth to python httplib2.
+
+WWW: https://github.com/maraujop/requests-oauth-hook
diff --git a/www/py-requests-oauth-hook/pkg-plist b/www/py-requests-oauth-hook/pkg-plist
new file mode 100644
index 000000000000..38da01d4406c
--- /dev/null
+++ b/www/py-requests-oauth-hook/pkg-plist
@@ -0,0 +1,25 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/oauth_hook/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/oauth_hook/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/oauth_hook/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/oauth_hook/hook.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/oauth_hook/hook.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/oauth_hook/hook.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tests/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tests/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tests/test_settings.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tests/test_settings.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tests/test_settings.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tests/tests.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tests/tests.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tests/tests.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/tests
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/oauth_hook
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%