aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/glibwww/Makefile3
-rw-r--r--www/gtkhtml/Makefile16
-rw-r--r--www/gtkhtml3/Makefile16
-rw-r--r--www/gtkhtml38/Makefile16
4 files changed, 17 insertions, 34 deletions
diff --git a/www/glibwww/Makefile b/www/glibwww/Makefile
index 9d584153172a..59b5948ac8ee 100644
--- a/www/glibwww/Makefile
+++ b/www/glibwww/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= wwwzip.1:${PORTSDIR}/www/libwww
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomelibs
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/www/gtkhtml/Makefile b/www/gtkhtml/Makefile
index e4986cf48449..9c97cee7a510 100644
--- a/www/gtkhtml/Makefile
+++ b/www/gtkhtml/Makefile
@@ -14,29 +14,23 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= glibwww.1:${PORTSDIR}/www/glibwww \
- pspell.4:${PORTSDIR}/textproc/pspell \
- gal.19:${PORTSDIR}/x11-toolkits/gal \
- ghttp.1:${PORTSDIR}/www/libghttp
+LIB_DEPENDS= pspell.4:${PORTSDIR}/textproc/pspell
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gnomehier glibwww gal ghttp libcapplet
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
-CONFIGURE_ARGS= --with-gconf=yes \
- --disable-gtk-doc
+CONFIGURE_ARGS= --with-gconf=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>
diff --git a/www/gtkhtml3/Makefile b/www/gtkhtml3/Makefile
index e4986cf48449..9c97cee7a510 100644
--- a/www/gtkhtml3/Makefile
+++ b/www/gtkhtml3/Makefile
@@ -14,29 +14,23 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= glibwww.1:${PORTSDIR}/www/glibwww \
- pspell.4:${PORTSDIR}/textproc/pspell \
- gal.19:${PORTSDIR}/x11-toolkits/gal \
- ghttp.1:${PORTSDIR}/www/libghttp
+LIB_DEPENDS= pspell.4:${PORTSDIR}/textproc/pspell
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gnomehier glibwww gal ghttp libcapplet
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
-CONFIGURE_ARGS= --with-gconf=yes \
- --disable-gtk-doc
+CONFIGURE_ARGS= --with-gconf=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>
diff --git a/www/gtkhtml38/Makefile b/www/gtkhtml38/Makefile
index e4986cf48449..9c97cee7a510 100644
--- a/www/gtkhtml38/Makefile
+++ b/www/gtkhtml38/Makefile
@@ -14,29 +14,23 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= glibwww.1:${PORTSDIR}/www/glibwww \
- pspell.4:${PORTSDIR}/textproc/pspell \
- gal.19:${PORTSDIR}/x11-toolkits/gal \
- ghttp.1:${PORTSDIR}/www/libghttp
+LIB_DEPENDS= pspell.4:${PORTSDIR}/textproc/pspell
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gnomehier glibwww gal ghttp libcapplet
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
-CONFIGURE_ARGS= --with-gconf=yes \
- --disable-gtk-doc
+CONFIGURE_ARGS= --with-gconf=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>