aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/webinject/Makefile58
-rw-r--r--www/webinject/distinfo3
-rw-r--r--www/webinject/files/patch-webinject.pl20
-rw-r--r--www/webinject/pkg-descr15
5 files changed, 97 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index caa66644c246..35dc176260b3 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1046,6 +1046,7 @@
SUBDIR += webcrawl
SUBDIR += webfs
SUBDIR += webglimpse
+ SUBDIR += webinject
SUBDIR += weblint
SUBDIR += weblint++
SUBDIR += webredirect
diff --git a/www/webinject/Makefile b/www/webinject/Makefile
new file mode 100644
index 000000000000..406facc3d2b0
--- /dev/null
+++ b/www/webinject/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: webinject
+# Date created: August 22nd 2006
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= webinject
+PORTVERSION= 1.41
+CATEGORIES= www perl5 devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= webinject
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= A tool for automated testing of web applications
+
+RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/mach/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
+ ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay
+
+.if !defined(WITHOUT_X11)
+# some work to do here
+#RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
+.endif
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES= bin/webinject.pl \
+ ${DATADIR:S,^${PREFIX}/,,}/config.xml \
+ ${DATADIR:S,^${PREFIX}/,,}/testcases.xml
+PLIST_DIRS= ${DATADIR:S,^${PREFIX}/,,}
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} *.xml ${DATADIR}
+ @cd ${WRKSRC} && ${INSTALL_SCRIPT} webinject.pl ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= LICENSE README
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/webinject/distinfo b/www/webinject/distinfo
new file mode 100644
index 000000000000..9b2c386b8676
--- /dev/null
+++ b/www/webinject/distinfo
@@ -0,0 +1,3 @@
+MD5 (webinject-1.41.src.tar.gz) = 5c90ddd69719d897afd8ccb2f8528163
+SHA256 (webinject-1.41.src.tar.gz) = e1bfc77d9673c15a06bc385992df9e28eb40101a8a9cd5ba18fdaa51aa43036b
+SIZE (webinject-1.41.src.tar.gz) = 29024
diff --git a/www/webinject/files/patch-webinject.pl b/www/webinject/files/patch-webinject.pl
new file mode 100644
index 000000000000..27b3b5007d0c
--- /dev/null
+++ b/www/webinject/files/patch-webinject.pl
@@ -0,0 +1,20 @@
+--- webinject.pl.orig Wed Jan 4 19:10:30 2006
++++ webinject.pl Mon Sep 4 16:19:08 2006
+@@ -1362,12 +1362,12 @@
+ #------------------------------------------------------------------
+ sub getdirname { #get the directory webinject engine is running from
+
+- $dirname = $0;
+- $dirname =~ s~(.*/).*~$1~; #for nix systems
+- $dirname =~ s~(.*\\).*~$1~; #for windoz systems
+- if ($dirname eq $0) {
++# $dirname = $0;
++# $dirname =~ s~(.*/).*~$1~; #for nix systems
++# $dirname =~ s~(.*\\).*~$1~; #for windoz systems
++# if ($dirname eq $0) {
+ $dirname = './';
+- }
++# }
+ }
+ #------------------------------------------------------------------
+ sub getoptions { #command line options
diff --git a/www/webinject/pkg-descr b/www/webinject/pkg-descr
new file mode 100644
index 000000000000..4af437932f31
--- /dev/null
+++ b/www/webinject/pkg-descr
@@ -0,0 +1,15 @@
+WebInject is a free tool for automated testing of web applications and web
+services. It can be used to test individual system components that have HTTP
+interfaces (JSP, ASP, CGI, PHP, Servlets, HTML Forms, XML/SOAP Web Services,
+etc), and can be used as a test harness to create a suite of [HTTP level]
+automated functional, acceptance, and regression tests. A test harness, also
+referred to as a test driver or a test framework, allows you to run many
+test cases and collect/report your results. WebInject offers real-time
+results display and may also be used for monitoring system response times.
+
+WebInject can be used as a complete test framework that is controlled by the
+WebInject User Interface (GUI). Optionally, it can be used as a standalone
+test runner (text/console application) which can be integrated and called
+from other test frameworks or applications.
+
+WWW: http://www.webinject.org/