aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/redmine/Makefile14
-rw-r--r--www/redmine/pkg-plist28
2 files changed, 20 insertions, 22 deletions
diff --git a/www/redmine/Makefile b/www/redmine/Makefile
index 04cffad9573a..33c15c17483c 100644
--- a/www/redmine/Makefile
+++ b/www/redmine/Makefile
@@ -3,7 +3,7 @@
PORTNAME= redmine
PORTVERSION= 2.6.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://www.redmine.org/releases/
@@ -22,7 +22,7 @@ RUN_DEPENDS= rubygem-builder>=3.0.0:${PORTSDIR}/devel/rubygem-builder \
rubygem-rails>=3.2.16:${PORTSDIR}/www/rubygem-rails \
rubygem-rake>=0:${PORTSDIR}/devel/rubygem-rake \
rubygem-rbpdf>=0:${PORTSDIR}/print/rubygem-rbpdf \
- rubygem-redcarpet>0:${PORTSDIR}/textproc/rubygem-redcarpet \
+ rubygem-redcarpet>=3.0:${PORTSDIR}/textproc/rubygem-redcarpet \
rubygem-request_store>=1.1.0:${PORTSDIR}/devel/rubygem-request_store \
rubygem-rubytree>=0:${PORTSDIR}/devel/rubygem-rubytree
@@ -69,7 +69,11 @@ RUN_DEPENDS+= passenger-config:${PORTSDIR}/www/rubygem-passenger
.endif
post-extract:
- ${MV} ${WRKSRC}/config/settings.yml ${WRKSRC}/config/settings.yml-dist
+ @${RM} ${WRKSRC}/.hgignore ${WRKSRC}/.travis.yml
+ @${MV} ${WRKSRC}/config/settings.yml ${WRKSRC}/config/settings.yml-dist
+
+post-patch:
+ @${FIND} ${WRKSRC} -name '*.bak' -o -name '*.orig' -delete
pre-install:
${MKDIR} ${WRKSRC}/public/plugin_assets
@@ -77,9 +81,7 @@ pre-install:
do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}
${MKDIR} ${STAGEDIR}${WWWDIR}/tmp/pids
- cd ${WRKSRC} && \
- ${COPYTREE_SHARE} "*" ${STAGEDIR}${WWWDIR} "! ( -name *\.orig -o -name *\.bak )"
- ${FIND} ${WRKSRC}/script -type f -print | ${XARGS} ${CHMOD} 755
+ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
post-install:
${TOUCH} ${STAGEDIR}${WWWDIR}/Gemfile.lock
diff --git a/www/redmine/pkg-plist b/www/redmine/pkg-plist
index 49206fef27cd..5e6a520218c7 100644
--- a/www/redmine/pkg-plist
+++ b/www/redmine/pkg-plist
@@ -855,7 +855,7 @@
%%WWWDIR%%/extra/sample_plugin/test/integration/routing_test.rb
%%WWWDIR%%/extra/svn/Redmine.pm
%%WWWDIR%%/extra/svn/reposman.rb
-%%WWWDIR%%/files/delete.me
+@(%%WWWOWN%%,%%WWWGRP%%,) %%WWWDIR%%/files/delete.me
%%WWWDIR%%/lib/SVG/GPL.txt
%%WWWDIR%%/lib/SVG/Graph/Bar.rb
%%WWWDIR%%/lib/SVG/Graph/BarBase.rb
@@ -1090,7 +1090,7 @@
%%WWWDIR%%/lib/tasks/reminder.rake
%%WWWDIR%%/lib/tasks/testing.rake
%%WWWDIR%%/lib/tasks/yardoc.rake
-%%WWWDIR%%/log/delete.me
+@(%%WWWOWN%%,%%WWWGRP%%,) %%WWWDIR%%/log/delete.me
%%WWWDIR%%/plugins/README
%%WWWDIR%%/public/404.html
%%WWWDIR%%/public/500.html
@@ -1427,7 +1427,7 @@
%%WWWDIR%%/public/javascripts/repository_navigation.js
%%WWWDIR%%/public/javascripts/revision_graph.js
%%WWWDIR%%/public/javascripts/select_list_move.js
-%%WWWDIR%%/public/plugin_assets/empty
+@(%%WWWOWN%%,%%WWWGRP%%,) %%WWWDIR%%/public/plugin_assets/empty
%%WWWDIR%%/public/stylesheets/application.css
%%WWWDIR%%/public/stylesheets/context_menu.css
%%WWWDIR%%/public/stylesheets/context_menu_rtl.css
@@ -1454,8 +1454,8 @@
%%WWWDIR%%/public/themes/classic/images/home.png
%%WWWDIR%%/public/themes/classic/images/wrench.png
%%WWWDIR%%/public/themes/classic/stylesheets/application.css
-%%WWWDIR%%/script/about
-%%WWWDIR%%/script/rails
+@(,,755) %%WWWDIR%%/script/about
+@(,,755) %%WWWDIR%%/script/rails
%%WWWDIR%%/test/extra/redmine_pm/repository_git_test.rb
%%WWWDIR%%/test/extra/redmine_pm/repository_subversion_test.rb
%%WWWDIR%%/test/extra/redmine_pm/test_case.rb
@@ -1842,20 +1842,16 @@
%%WWWDIR%%/test/unit/wiki_test.rb
%%WWWDIR%%/test/unit/workflow_test.rb
%%WWWDIR%%/test/unit/workflow_transition_test.rb
-%%WWWDIR%%/tmp/pdf/empty
-%%WWWDIR%%/tmp/test/empty
-%%WWWDIR%%/tmp/thumbnails/empty
+@(%%WWWOWN%%,%%WWWGRP%%,) %%WWWDIR%%/tmp/pdf/empty
+@(%%WWWOWN%%,%%WWWGRP%%,) %%WWWDIR%%/tmp/test/empty
+@(%%WWWOWN%%,%%WWWGRP%%,) %%WWWDIR%%/tmp/thumbnails/empty
@dir %%WWWDIR%%/app/sweepers
@dir %%WWWDIR%%/lib/vendor
@dir %%WWWDIR%%/test/fixtures/mailer
@dir %%WWWDIR%%/test/mocks/development
@dir %%WWWDIR%%/test/mocks/test
-@dir %%WWWDIR%%/tmp/cache
-@dir %%WWWDIR%%/tmp/pids
-@dir %%WWWDIR%%/tmp/sessions
-@dir %%WWWDIR%%/tmp/sockets
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%WWWDIR%%/tmp/cache
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%WWWDIR%%/tmp/pids
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%WWWDIR%%/tmp/sessions
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%WWWDIR%%/tmp/sockets
@dir %%WWWDIR%%/vendor
-@exec chown -R %%WWWOWN%%:%%WWWGRP%% %D/%%WWWDIR%%/files
-@exec chown -R %%WWWOWN%%:%%WWWGRP%% %D/%%WWWDIR%%/log
-@exec chown -R %%WWWOWN%%:%%WWWGRP%% %D/%%WWWDIR%%/public/plugin_assets
-@exec chown -R %%WWWOWN%%:%%WWWGRP%% %D/%%WWWDIR%%/tmp