aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/apache13-modperl/Makefile6
-rw-r--r--www/dtse/Makefile8
-rw-r--r--www/fswiki/Makefile12
-rw-r--r--www/p5-Apache-ASP/Makefile11
-rw-r--r--www/p5-Apache-AuthTicket/Makefile8
-rw-r--r--www/p5-Apache-DBI/Makefile8
-rw-r--r--www/p5-Apache-Gallery/Makefile9
-rw-r--r--www/p5-Apache-MP3/Makefile9
-rw-r--r--www/p5-Bundle-Sledge/Makefile8
-rw-r--r--www/p5-CGI-Application-Plugin-Authorization/Makefile6
-rw-r--r--www/p5-CGI-Application/Makefile9
-rw-r--r--www/p5-CGI-Cache/Makefile8
-rw-r--r--www/p5-CGI-Ex/Makefile11
-rw-r--r--www/p5-CGI-Kwiki/Makefile13
-rw-r--r--www/p5-CGI-Session/Makefile9
-rw-r--r--www/p5-Catalyst-Plugin-Scheduler/Makefile8
-rw-r--r--www/p5-FAQ-OMatic/Makefile9
-rw-r--r--www/p5-HTML-Template/Makefile10
-rw-r--r--www/p5-HTML-TreeBuilder-XPath/Makefile8
-rw-r--r--www/p5-HTTP-WebTest/Makefile14
-rw-r--r--www/p5-LWPx-ParanoidAgent/Makefile8
-rw-r--r--www/p5-URI-Fetch/Makefile14
-rw-r--r--www/p5-WWW-Facebook-API/Makefile8
-rw-r--r--www/p5-WWW-Mixi/Makefile13
-rw-r--r--www/p5-WWW-Search-MSN/Makefile12
-rw-r--r--www/p5-WWW-Search/Makefile8
-rw-r--r--www/p5-WWW-Spinn3r/Makefile9
-rw-r--r--www/p5-libwww/Makefile8
-rw-r--r--www/perlbal/Makefile8
-rw-r--r--www/reportmagic/Makefile8
30 files changed, 36 insertions, 244 deletions
diff --git a/www/apache13-modperl/Makefile b/www/apache13-modperl/Makefile
index fa6b538e0ba7..71e16210c94f 100644
--- a/www/apache13-modperl/Makefile
+++ b/www/apache13-modperl/Makefile
@@ -138,17 +138,13 @@ MAN3= Apache.3 Apache::Constants.3 Apache::ExtUtils.3 \
Bundle::Apache.3 \
Apache::Debug.3 mod_perl.3 Apache::SIG.3 Apache::Resource.3 \
Apache::RegistryLoader.3 Apache::StatINC.3 Apache::Include.3 \
- Apache::PerlSections.3 cgi_to_mod_perl.3 \
+ Apache::PerlSections.3 Apache::MyConfig.3 cgi_to_mod_perl.3 \
mod_perl_cvs.3 mod_perl_method_handlers.3 mod_perl_traps.3 \
mod_perl_tuning.3
MAN8= ab.8 apachectl.8 apxs.8 httpd.8 logresolve.8 rotatelogs.8 \
${SUEXEC_MAN}
-.if ${PERL_LEVEL} >= 500800
-MAN3+= Apache::MyConfig.3
-.endif
-
pre-configure:
@ cd ${WRKSRC_MODPERL}; \
${PERL5} Makefile.PL EVERYTHING=1 APACHE_SRC=../apache_${VERSION_APACHE}\
diff --git a/www/dtse/Makefile b/www/dtse/Makefile
index f813d520d78f..96504a8791ab 100644
--- a/www/dtse/Makefile
+++ b/www/dtse/Makefile
@@ -30,10 +30,4 @@ MAKEFILE= GNUmakefile
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/fswiki/Makefile b/www/fswiki/Makefile
index 84f2cb530f7a..ff6846095a59 100644
--- a/www/fswiki/Makefile
+++ b/www/fswiki/Makefile
@@ -22,6 +22,8 @@ USE_ZIP= yes
USE_PERL5= yes
NO_BUILD= yes
+JCODE= ${SITE_PERL}/Jcode.pm
+
post-extract:
${SED} -e 's|__DATADIR__|${DATADIR}|' ${FILESDIR}/setup.sh \
>${WRKSRC}/setup.sh
@@ -39,12 +41,4 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/wiki.cgi ${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/setup.sh ${DATADIR}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500801
-JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
-.else
-JCODE= ${SITE_PERL}/Jcode.pm
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-ASP/Makefile b/www/p5-Apache-ASP/Makefile
index 37cafd725163..06cd21e6d2a0 100644
--- a/www/p5-Apache-ASP/Makefile
+++ b/www/p5-Apache-ASP/Makefile
@@ -43,13 +43,4 @@ MAN3= Apache::ASP.3 \
Bundle::Apache::ASP.3 \
Bundle::Apache::ASP::Extra.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-AuthTicket/Makefile b/www/p5-Apache-AuthTicket/Makefile
index a3bf7945c559..90cd8f06248c 100644
--- a/www/p5-Apache-AuthTicket/Makefile
+++ b/www/p5-Apache-AuthTicket/Makefile
@@ -23,10 +23,4 @@ PERL_CONFIGURE= yes
MAN3= Apache::AuthTicket.3 Apache2::AuthTicket.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-DBI/Makefile b/www/p5-Apache-DBI/Makefile
index ee75fd653a83..5c054d3fdb03 100644
--- a/www/p5-Apache-DBI/Makefile
+++ b/www/p5-Apache-DBI/Makefile
@@ -42,10 +42,4 @@ PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache \
%%SITE_PERL%%/Apache
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-Gallery/Makefile b/www/p5-Apache-Gallery/Makefile
index a0e8c2651b3b..9c64f4d4717e 100644
--- a/www/p5-Apache-Gallery/Makefile
+++ b/www/p5-Apache-Gallery/Makefile
@@ -61,11 +61,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-MP3/Makefile b/www/p5-Apache-MP3/Makefile
index d5eb1939b2e6..147341136cc1 100644
--- a/www/p5-Apache-MP3/Makefile
+++ b/www/p5-Apache-MP3/Makefile
@@ -34,11 +34,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/apache_mp3/* ${DATADIR}
${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/Locale/Maketext.pm:${PORTSDIR}/devel/p5-Locale-Maketext
-RUN_DEPENDS+= ${SITE_PERL}/Locale/Maketext.pm:${PORTSDIR}/devel/p5-Locale-Maketext
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Bundle-Sledge/Makefile b/www/p5-Bundle-Sledge/Makefile
index 0234c451deb0..041de4b810d7 100644
--- a/www/p5-Bundle-Sledge/Makefile
+++ b/www/p5-Bundle-Sledge/Makefile
@@ -49,12 +49,6 @@ PERL_CONFIGURE= yes
MAN3= Bundle::Sledge.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500801
-JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
-.else
JCODE= ${SITE_PERL}/Jcode.pm
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Application-Plugin-Authorization/Makefile b/www/p5-CGI-Application-Plugin-Authorization/Makefile
index d7e32fb683a2..3b84858b2a6e 100644
--- a/www/p5-CGI-Application-Plugin-Authorization/Makefile
+++ b/www/p5-CGI-Application-Plugin-Authorization/Makefile
@@ -33,8 +33,4 @@ MAN3= CGI::Application::Plugin::Authorization::Driver::Generic.3 \
CGI::Application::Plugin::Authorization.3 \
CGI::Application::Plugin::Authorization::Driver::HTGroup.3
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires Perl 5.8 or newer. Install lang/perl5.8, and try again
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Application/Makefile b/www/p5-CGI-Application/Makefile
index a61dd165479f..7e3a64de7a95 100644
--- a/www/p5-CGI-Application/Makefile
+++ b/www/p5-CGI-Application/Makefile
@@ -20,11 +20,4 @@ PERL_CONFIGURE= yes
MAN3= CGI::Application.3 CGI::Application::Mailform.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Class-ISA>=0:${PORTSDIR}/devel/p5-Class-ISA \
- p5-Net>=0:${PORTSDIR}/net/p5-Net
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Cache/Makefile b/www/p5-CGI-Cache/Makefile
index bf2e094231d6..737f9c840496 100644
--- a/www/p5-CGI-Cache/Makefile
+++ b/www/p5-CGI-Cache/Makefile
@@ -23,10 +23,4 @@ PERL_CONFIGURE= yes
MAN3= CGI::Cache.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Storable>=0:${PORTSDIR}/devel/p5-Storable
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Ex/Makefile b/www/p5-CGI-Ex/Makefile
index 3f1fc8cfa863..d2636e52c3da 100644
--- a/www/p5-CGI-Ex/Makefile
+++ b/www/p5-CGI-Ex/Makefile
@@ -36,13 +36,4 @@ post-install:
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
- p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
- p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Kwiki/Makefile b/www/p5-CGI-Kwiki/Makefile
index 2488f5cb81fa..043cac5ed8c2 100644
--- a/www/p5-CGI-Kwiki/Makefile
+++ b/www/p5-CGI-Kwiki/Makefile
@@ -40,15 +40,4 @@ MAN3= CGI::Kwiki.3 \
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-# Damn ExtUtils::MM_Unix, and Damn Module::Install !!!
-post-configure:
- @${PERL} -pi -e 'if (/MAN3PODS/) { $$_ .= "\tlib/CGI/Kwiki/Config.pm \\\n\tlib/CGI/Kwiki/Config_yaml.pm \\\n" };' \
- -e 'if (/manifypods :/) {$$_ .= "\tlib/CGI/Kwiki/Config.pm \\\n\tlib/CGI/Kwiki/Config_yaml.pm \\\n" };' \
- -e 'if (/\@\$$\(POD2MAN\)/) { $$_ .= "\tlib/CGI/Kwiki/Config.pm \\\n\t\$$(INST_MAN3DIR)/CGI::Kwiki::Config.\$$(MAN3EXT) \\\n\tlib/CGI/Kwiki/Config_yaml.pm \\\n\t\$$(INST_MAN3DIR)/CGI::Kwiki::Config_yaml.\$$(MAN3EXT) \\\n"};' \
- ${WRKSRC}/Makefile
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Session/Makefile b/www/p5-CGI-Session/Makefile
index a24dec1d928a..602021f1a692 100644
--- a/www/p5-CGI-Session/Makefile
+++ b/www/p5-CGI-Session/Makefile
@@ -36,11 +36,4 @@ MAN3= \
CGI::Session::Test::Default.3 \
CGI::Session::Tutorial.3 \
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS= ${BUILD_DEPENDS}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Plugin-Scheduler/Makefile b/www/p5-Catalyst-Plugin-Scheduler/Makefile
index 006417db25cd..6d99e46a89ff 100644
--- a/www/p5-Catalyst-Plugin-Scheduler/Makefile
+++ b/www/p5-Catalyst-Plugin-Scheduler/Makefile
@@ -25,10 +25,4 @@ PERL_MODBUILD= yes
MAN3= Catalyst::Plugin::Scheduler.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500801
-IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-FAQ-OMatic/Makefile b/www/p5-FAQ-OMatic/Makefile
index 4ddac0e7195d..6f4e2d1662de 100644
--- a/www/p5-FAQ-OMatic/Makefile
+++ b/www/p5-FAQ-OMatic/Makefile
@@ -21,11 +21,4 @@ MAN3= FAQ::OMatic::API.3
post-install:
@${CAT} ${WRKSRC}/install.notes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS= ${BUILD_DEPENDS}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Template/Makefile b/www/p5-HTML-Template/Makefile
index a5e9ca8bb079..700de140a86c 100644
--- a/www/p5-HTML-Template/Makefile
+++ b/www/p5-HTML-Template/Makefile
@@ -19,12 +19,4 @@ PERL_CONFIGURE= yes
MAN3= HTML::Template.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
- p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- p5-Storable>=0:${PORTSDIR}/devel/p5-Storable
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-TreeBuilder-XPath/Makefile b/www/p5-HTML-TreeBuilder-XPath/Makefile
index ef9590250c0d..4e2eaf5e9426 100644
--- a/www/p5-HTML-TreeBuilder-XPath/Makefile
+++ b/www/p5-HTML-TreeBuilder-XPath/Makefile
@@ -22,10 +22,4 @@ PERL_CONFIGURE= yes
MAN3= HTML::TreeBuilder::XPath.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-WebTest/Makefile b/www/p5-HTTP-WebTest/Makefile
index 743c7f0f613f..6b40b73a4bd6 100644
--- a/www/p5-HTTP-WebTest/Makefile
+++ b/www/p5-HTTP-WebTest/Makefile
@@ -46,16 +46,4 @@ MAN3= Bundle::HTTP::WebTest.3 \
HTTP::WebTest::Test.3 HTTP::WebTest::TestResult.3 \
HTTP::WebTest::Utils.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS_56= \
- ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
- ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced \
- ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
- ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
-.endif
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-LWPx-ParanoidAgent/Makefile b/www/p5-LWPx-ParanoidAgent/Makefile
index 103589a27e21..42cd7a37d03e 100644
--- a/www/p5-LWPx-ParanoidAgent/Makefile
+++ b/www/p5-LWPx-ParanoidAgent/Makefile
@@ -22,10 +22,4 @@ PERL_CONFIGURE= yes
MAN3= LWPx::ParanoidAgent.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-BUILD_DEPENDS+= ${SITE_PERL}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-URI-Fetch/Makefile b/www/p5-URI-Fetch/Makefile
index 58fb7601ae96..068984c5c1d1 100644
--- a/www/p5-URI-Fetch/Makefile
+++ b/www/p5-URI-Fetch/Makefile
@@ -29,15 +29,6 @@ PERL_CONFIGURE= yes
MAN3= URI::Fetch.3 \
URI::Fetch::Response.3
-post-patch:
- ${PERL} -pi -e '$$_ = "" if m|auto_install|' ${WRKSRC}/Makefile.PL
-
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Storable>=0:${PORTSDIR}/devel/p5-Storable
-.endif
-
.if !defined(WITHOUT_ZLIB)
RUN_DEPENDS+= p5-Compress-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Zlib
.endif
@@ -46,4 +37,7 @@ RUN_DEPENDS+= p5-Compress-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Zlib
RUN_DEPENDS+= p5-Cache>=0:${PORTSDIR}/devel/p5-Cache
.endif
-.include <bsd.port.post.mk>
+post-patch:
+ ${PERL} -pi -e '$$_ = "" if m|auto_install|' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Facebook-API/Makefile b/www/p5-WWW-Facebook-API/Makefile
index 8254a5010740..1834825dcf6d 100644
--- a/www/p5-WWW-Facebook-API/Makefile
+++ b/www/p5-WWW-Facebook-API/Makefile
@@ -44,10 +44,4 @@ MAN3= WWW::Facebook::API.3 \
WWW::Facebook::API::SMS.3 \
WWW::Facebook::API::Users.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Mixi/Makefile b/www/p5-WWW-Mixi/Makefile
index e20e969d0996..48f6c22d083a 100644
--- a/www/p5-WWW-Mixi/Makefile
+++ b/www/p5-WWW-Mixi/Makefile
@@ -14,19 +14,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kaoru@kaisei.org
COMMENT= Perl module of Automated interface to the Mixi
-BUILD_DEPENDS= ${SITE_PERL}/LWP/RobotUA.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${SITE_PERL}/LWP/RobotUA.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= WWW::Mixi.3 WWW::Mixi::Cookbook.3 WWW::Mixi::Mixi.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} > 500800
-BUILD_DEPENDS+= ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Search-MSN/Makefile b/www/p5-WWW-Search-MSN/Makefile
index e0b07b563ffd..763640bb112c 100644
--- a/www/p5-WWW-Search-MSN/Makefile
+++ b/www/p5-WWW-Search-MSN/Makefile
@@ -22,14 +22,4 @@ PERL_CONFIGURE= yes
MAN3= WWW::Search::MSN.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500701
-BUILD_DEPENDS+= ${SITE_PERL}/Encode.pm:${PORTSDIR}/converters/p5-Encode
-.endif
-
-.if ${PERL_LEVEL} < 500702
-BUILD_DEPENDS+= ${SITE_PERL}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Search/Makefile b/www/p5-WWW-Search/Makefile
index c8d3b7af8aef..0405a8b85ced 100644
--- a/www/p5-WWW-Search/Makefile
+++ b/www/p5-WWW-Search/Makefile
@@ -45,10 +45,4 @@ MAN3= WWW::Search.3 \
WWW::Search::Simple.3 \
WWW::Search::Test.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Net>=0:${PORTSDIR}/net/p5-Net
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Spinn3r/Makefile b/www/p5-WWW-Spinn3r/Makefile
index a13420aadd9c..060d08c21ca1 100644
--- a/www/p5-WWW-Spinn3r/Makefile
+++ b/www/p5-WWW-Spinn3r/Makefile
@@ -26,11 +26,4 @@ PERL_CONFIGURE= yes
MAN3= WWW::Spinn3r.3 \
WWW::Spinn3r::Synced.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Storable>=0:${PORTSDIR}/devel/p5-Storable \
- p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-libwww/Makefile b/www/p5-libwww/Makefile
index 21e31c1951b8..bc1c6d4f2424 100644
--- a/www/p5-libwww/Makefile
+++ b/www/p5-libwww/Makefile
@@ -38,15 +38,7 @@ MAN3= Bundle::LWP.3 File::Listing.3 HTML::Form.3 HTTP::Config.3 \
WWW::RobotRules::AnyDBM_File.3 lwpcook.3 lwptut.3
.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
- p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
- p5-Net>=2.58:${PORTSDIR}/net/p5-Net
-.endif
-
.if ${PERL_LEVEL} < 500903
RUN_DEPENDS+= p5-Compress-Zlib>=1.10:${PORTSDIR}/archivers/p5-Compress-Zlib
.endif
-
.include <bsd.port.post.mk>
diff --git a/www/perlbal/Makefile b/www/perlbal/Makefile
index 1bc1ca67c70e..c269495f4153 100644
--- a/www/perlbal/Makefile
+++ b/www/perlbal/Makefile
@@ -32,16 +32,10 @@ MAN3= Perlbal.3 \
Perlbal::Test.3 \
Perlbal::Util.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
-.endif
-
.ifndef NOPORTDOCS
post-install:
${MKDIR} ${DOCSDIR}
${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/reportmagic/Makefile b/www/reportmagic/Makefile
index 9b7787d6b015..ea31fa06ea52 100644
--- a/www/reportmagic/Makefile
+++ b/www/reportmagic/Makefile
@@ -38,10 +38,4 @@ post-install:
@${ECHO} "using Report Magic."
@${ECHO}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>