aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/bozohttpd/Makefile1
-rw-r--r--www/bozohttpd/pkg-plist1
-rw-r--r--www/cgi-lib.pl/Makefile1
-rw-r--r--www/cgi-lib.pl/pkg-plist1
-rw-r--r--www/demoroniser/Makefile1
-rw-r--r--www/demoroniser/pkg-plist1
-rw-r--r--www/flashpluginwrapper/Makefile1
-rw-r--r--www/flashpluginwrapper/pkg-plist1
-rw-r--r--www/html2hdml/Makefile1
-rw-r--r--www/html2hdml/pkg-plist1
-rw-r--r--www/http_get/Makefile1
-rw-r--r--www/http_get/pkg-plist1
-rw-r--r--www/http_load/Makefile1
-rw-r--r--www/http_load/pkg-plist1
-rw-r--r--www/httpgrabber/Makefile1
-rw-r--r--www/httpgrabber/pkg-plist1
-rw-r--r--www/indexme/Makefile1
-rw-r--r--www/indexme/pkg-plist1
-rw-r--r--www/links/Makefile1
-rw-r--r--www/links/pkg-plist1
-rw-r--r--www/micro_httpd/Makefile1
-rw-r--r--www/micro_httpd/pkg-plist1
-rw-r--r--www/mod_encoding/Makefile1
-rw-r--r--www/mod_encoding/pkg-plist1
-rw-r--r--www/mod_limitipconn/Makefile1
-rw-r--r--www/mod_limitipconn/pkg-plist1
-rw-r--r--www/nd/Makefile1
-rw-r--r--www/nd/pkg-plist1
-rw-r--r--www/netscape-wrapper/Makefile1
-rw-r--r--www/netscape-wrapper/pkg-plist1
-rw-r--r--www/nspostgres/Makefile1
-rw-r--r--www/nspostgres/pkg-plist1
-rw-r--r--www/pgdriver/Makefile1
-rw-r--r--www/pgdriver/pkg-plist1
-rw-r--r--www/ruby-tmpl/Makefile2
-rw-r--r--www/ruby-tmpl/pkg-plist1
-rw-r--r--www/squidclients/Makefile1
-rw-r--r--www/squidclients/pkg-plist1
-rw-r--r--www/squidpurge/Makefile1
-rw-r--r--www/squidpurge/pkg-plist1
-rw-r--r--www/squidtimes/Makefile1
-rw-r--r--www/squidtimes/pkg-plist1
-rw-r--r--www/web-traceroute/Makefile1
-rw-r--r--www/web-traceroute/pkg-plist1
-rw-r--r--www/webcrawl/Makefile1
-rw-r--r--www/webcrawl/pkg-plist1
-rw-r--r--www/webredirect/Makefile1
-rw-r--r--www/webredirect/pkg-plist1
-rw-r--r--www/wmnetselect/Makefile1
-rw-r--r--www/wmnetselect/pkg-plist1
50 files changed, 26 insertions, 25 deletions
diff --git a/www/bozohttpd/Makefile b/www/bozohttpd/Makefile
index f016162d2288..7695c2bf1f02 100644
--- a/www/bozohttpd/Makefile
+++ b/www/bozohttpd/Makefile
@@ -22,5 +22,6 @@ MAKE_ARGS+= 'LDFLAGS+= -lcrypt'
MAN8= bozohttpd.8
MANCOMPRESSED= maybe
+PLIST_FILES= libexec/bozohttpd
.include <bsd.port.mk>
diff --git a/www/bozohttpd/pkg-plist b/www/bozohttpd/pkg-plist
deleted file mode 100644
index 80b77b4b17b8..000000000000
--- a/www/bozohttpd/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-libexec/bozohttpd
diff --git a/www/cgi-lib.pl/Makefile b/www/cgi-lib.pl/Makefile
index d151ee6eff72..02ad8ac8fe73 100644
--- a/www/cgi-lib.pl/Makefile
+++ b/www/cgi-lib.pl/Makefile
@@ -19,6 +19,7 @@ COMMENT= De facto standard library for creating CGI in perl
USE_PERL5= YES
NO_BUILD= YES
NO_WRKSUBDIR= YES
+PLIST_FILES= %%SITE_PERL%%/cgi-lib.pl
EXTRACT_AFTER_ARGS= > cgi-lib.pl
INSTALL_BASE= lib/perl5/site_perl/${PERL_VER}
diff --git a/www/cgi-lib.pl/pkg-plist b/www/cgi-lib.pl/pkg-plist
deleted file mode 100644
index ee56a48cfcf1..000000000000
--- a/www/cgi-lib.pl/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-%%SITE_PERL%%/cgi-lib.pl
diff --git a/www/demoroniser/Makefile b/www/demoroniser/Makefile
index 4077494494b0..6a634d0f4e69 100644
--- a/www/demoroniser/Makefile
+++ b/www/demoroniser/Makefile
@@ -21,6 +21,7 @@ NO_BUILD= yes
NO_WRKSUBDIR= yes
MAN1= demoroniser.1
+PLIST_FILES= bin/demoroniser
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/demoroniser.pl ${PREFIX}/bin/demoroniser
diff --git a/www/demoroniser/pkg-plist b/www/demoroniser/pkg-plist
deleted file mode 100644
index 343802b3594b..000000000000
--- a/www/demoroniser/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/demoroniser
diff --git a/www/flashpluginwrapper/Makefile b/www/flashpluginwrapper/Makefile
index 29e0428bf0c3..8351fcd7ddf7 100644
--- a/www/flashpluginwrapper/Makefile
+++ b/www/flashpluginwrapper/Makefile
@@ -24,6 +24,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
CONFLICTS= linuxpluginwrapper-*
IGNORE= "Please use www/linuxpluginwrapper. This port should be obsolated. But, if you cannot use it by any reason, please set NO_IGNORE and you can use this."
+PLIST_FILES= lib/libflashplayer.so.1
post-patch:
@${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},' \
diff --git a/www/flashpluginwrapper/pkg-plist b/www/flashpluginwrapper/pkg-plist
deleted file mode 100644
index b0efcdfe7ec3..000000000000
--- a/www/flashpluginwrapper/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-lib/libflashplayer.so.1
diff --git a/www/html2hdml/Makefile b/www/html2hdml/Makefile
index e11001824e06..1572c52fe727 100644
--- a/www/html2hdml/Makefile
+++ b/www/html2hdml/Makefile
@@ -15,5 +15,6 @@ MAINTAINER= knu@FreeBSD.org
COMMENT= An i-mode HTML to EZweb HDML converter
GNU_CONFIGURE= yes
+PLIST_FILES= bin/html2hdml
.include <bsd.port.mk>
diff --git a/www/html2hdml/pkg-plist b/www/html2hdml/pkg-plist
deleted file mode 100644
index ae81351ba887..000000000000
--- a/www/html2hdml/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/html2hdml
diff --git a/www/http_get/Makefile b/www/http_get/Makefile
index 25c3ca1074be..650686b83153 100644
--- a/www/http_get/Makefile
+++ b/www/http_get/Makefile
@@ -18,5 +18,6 @@ WRKSRC= ${WRKDIR}/http_get
MAN1= http_get.1
MANCOMPRESSED= no
+PLIST_FILES= bin/http_get
.include <bsd.port.mk>
diff --git a/www/http_get/pkg-plist b/www/http_get/pkg-plist
deleted file mode 100644
index bef821527971..000000000000
--- a/www/http_get/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/http_get
diff --git a/www/http_load/Makefile b/www/http_load/Makefile
index 7b66bba7b7d9..acd12cff85b4 100644
--- a/www/http_load/Makefile
+++ b/www/http_load/Makefile
@@ -19,6 +19,7 @@ MAKEFILE= ${FILESDIR}/Makefile.bsd
MAN1= http_load.1
MANCOMPRESSED= maybe
+PLIST_FILES= bin/http_load
.ifndef NO_OPENSSL
USE_OPENSSL= yes
diff --git a/www/http_load/pkg-plist b/www/http_load/pkg-plist
deleted file mode 100644
index f0df23721520..000000000000
--- a/www/http_load/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/http_load
diff --git a/www/httpgrabber/Makefile b/www/httpgrabber/Makefile
index c0bdda1417e3..e22dc6f93d26 100644
--- a/www/httpgrabber/Makefile
+++ b/www/httpgrabber/Makefile
@@ -16,5 +16,6 @@ COMMENT= HTTP network traffic grabber and extractor
LIB_DEPENDS= ngrep.1:${PORTSDIR}/net/ngrep-lib
MAN8= httpgrabber.8
+PLIST_FILES= bin/httpgrabber
.include <bsd.port.mk>
diff --git a/www/httpgrabber/pkg-plist b/www/httpgrabber/pkg-plist
deleted file mode 100644
index 7db2b8969cfb..000000000000
--- a/www/httpgrabber/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/httpgrabber
diff --git a/www/indexme/Makefile b/www/indexme/Makefile
index 2fa96f72c44e..1c4871e1f183 100644
--- a/www/indexme/Makefile
+++ b/www/indexme/Makefile
@@ -19,6 +19,7 @@ USE_PERL5= yes
WRKSRC= ${WRKDIR}/indexme
NO_BUILD= yes
MAN1= indexme.1
+PLIST_FILES= bin/indexme
do-install:
@ ${INSTALL_SCRIPT} ${WRKSRC}/indexme ${PREFIX}/bin
diff --git a/www/indexme/pkg-plist b/www/indexme/pkg-plist
deleted file mode 100644
index 3566dd727447..000000000000
--- a/www/indexme/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/indexme
diff --git a/www/links/Makefile b/www/links/Makefile
index 74b8fe7fe4cc..25c47bc8d601 100644
--- a/www/links/Makefile
+++ b/www/links/Makefile
@@ -35,6 +35,7 @@ CONFIGURE_ARGS+= --enable-graphics --with-x
.endif
MAN1= links.1
+PLIST_FILES= bin/links
pre-everything::
@${ECHO_MSG} "Define WITHOUT_X11 to disable graphics support."
diff --git a/www/links/pkg-plist b/www/links/pkg-plist
deleted file mode 100644
index 191550099363..000000000000
--- a/www/links/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/links
diff --git a/www/micro_httpd/Makefile b/www/micro_httpd/Makefile
index 75b2610653bc..d35c8da9d3cb 100644
--- a/www/micro_httpd/Makefile
+++ b/www/micro_httpd/Makefile
@@ -18,6 +18,7 @@ COMMENT= An extremely small web server
USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
MAN8= micro_httpd.8
+PLIST_FILES= sbin/micro_httpd
post-patch:
@${REINPLACE_CMD} -e "s:/usr/local/sbin:${PREFIX}/sbin:g; \
diff --git a/www/micro_httpd/pkg-plist b/www/micro_httpd/pkg-plist
deleted file mode 100644
index e3e349c84e1a..000000000000
--- a/www/micro_httpd/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-sbin/micro_httpd
diff --git a/www/mod_encoding/Makefile b/www/mod_encoding/Makefile
index dc576913fa23..d4257752c458 100644
--- a/www/mod_encoding/Makefile
+++ b/www/mod_encoding/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
# Mostly because of the dependency of mod_dav.
APACHE_VERSION= 1.3.6
+PLIST_FILES= libexec/apache/mod_encoding.so
USE_APACHE= yes
HAS_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/www/mod_encoding/pkg-plist b/www/mod_encoding/pkg-plist
deleted file mode 100644
index 5f266b13afaa..000000000000
--- a/www/mod_encoding/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-libexec/apache/mod_encoding.so
diff --git a/www/mod_limitipconn/Makefile b/www/mod_limitipconn/Makefile
index 5b4bfede3bb1..7f04d66d4634 100644
--- a/www/mod_limitipconn/Makefile
+++ b/www/mod_limitipconn/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= http://dominia.org/djao/limit/
MAINTAINER= gslin@ccca.nctu.edu.tw
COMMENT= Limit the number of simultaneous connections from a single client IP address
+PLIST_FILES= libexec/apache/mod_limitipconn.so
USE_APACHE= yes
USE_REINPLACE= yes
diff --git a/www/mod_limitipconn/pkg-plist b/www/mod_limitipconn/pkg-plist
deleted file mode 100644
index 088149d887a4..000000000000
--- a/www/mod_limitipconn/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-libexec/apache/mod_limitipconn.so
diff --git a/www/nd/Makefile b/www/nd/Makefile
index 479fbadad1fd..862bfd84b0ed 100644
--- a/www/nd/Makefile
+++ b/www/nd/Makefile
@@ -18,5 +18,6 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
GNU_CONFIGURE= yes
MAN1= nd.1
+PLIST_FILES= bin/nd
.include <bsd.port.mk>
diff --git a/www/nd/pkg-plist b/www/nd/pkg-plist
deleted file mode 100644
index a80b33155e40..000000000000
--- a/www/nd/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/nd
diff --git a/www/netscape-wrapper/Makefile b/www/netscape-wrapper/Makefile
index a4dd46130815..950df3201871 100644
--- a/www/netscape-wrapper/Makefile
+++ b/www/netscape-wrapper/Makefile
@@ -17,6 +17,7 @@ COMMENT= Netscape wrapper to avoid multiple invocation and more
RUN_DEPENDS= netscape-remote:${PORTSDIR}/www/netscape-remote
NO_WRKSUBDIR= yes
+PLIST_FILES= bin/netscape
do-build:
${SED} 's,%%PREFIX%%,${PREFIX},g' ${FILESDIR}/netscape.sh > ${WRKSRC}/netscape.sh
diff --git a/www/netscape-wrapper/pkg-plist b/www/netscape-wrapper/pkg-plist
deleted file mode 100644
index c5bc755e5588..000000000000
--- a/www/netscape-wrapper/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/netscape
diff --git a/www/nspostgres/Makefile b/www/nspostgres/Makefile
index 18270ccaf1a5..333d3ba69a07 100644
--- a/www/nspostgres/Makefile
+++ b/www/nspostgres/Makefile
@@ -26,6 +26,7 @@ WRKSRC= ${WRKDIR}/nspostgres
USE_GMAKE= yes
MAKE_ENV+= POSTGRES=${PREFIX} BUILDPREFIX=${PREFIX}
+PLIST_FILES= aolserver/bin/nspostgres.so
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/nspostgres.so ${PREFIX}/aolserver/bin
diff --git a/www/nspostgres/pkg-plist b/www/nspostgres/pkg-plist
deleted file mode 100644
index d8340ba95ac5..000000000000
--- a/www/nspostgres/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-aolserver/bin/nspostgres.so
diff --git a/www/pgdriver/Makefile b/www/pgdriver/Makefile
index 2b591cee865f..a5b357a1a364 100644
--- a/www/pgdriver/Makefile
+++ b/www/pgdriver/Makefile
@@ -23,5 +23,6 @@ POSTGRESQL_PORT?= databases/postgresql7
MAKEFILE= makefile
MAKE_ENV+= PREFIX=${PREFIX}
+PLIST_FILES= aolserver/bin/postgres.so
.include <bsd.port.mk>
diff --git a/www/pgdriver/pkg-plist b/www/pgdriver/pkg-plist
deleted file mode 100644
index 91d5ed0ce004..000000000000
--- a/www/pgdriver/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-aolserver/bin/postgres.so
diff --git a/www/ruby-tmpl/Makefile b/www/ruby-tmpl/Makefile
index 0b9496274e7b..b2ba9f64d1a3 100644
--- a/www/ruby-tmpl/Makefile
+++ b/www/ruby-tmpl/Makefile
@@ -21,6 +21,8 @@ USE_RUBY= yes
NO_BUILD= yes
+PLIST_FILES= %%RUBY_SITELIBDIR%%/ruby-tmpl.rb
+
do-install:
cd ${WRKSRC}; ${RUBY} install.rb
diff --git a/www/ruby-tmpl/pkg-plist b/www/ruby-tmpl/pkg-plist
deleted file mode 100644
index 4d6fca1165dc..000000000000
--- a/www/ruby-tmpl/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-%%RUBY_SITELIBDIR%%/ruby-tmpl.rb
diff --git a/www/squidclients/Makefile b/www/squidclients/Makefile
index 9d7455cf811a..d6ce4352c9c6 100644
--- a/www/squidclients/Makefile
+++ b/www/squidclients/Makefile
@@ -21,6 +21,7 @@ NO_WRKSUBDIR= YES
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= .
+PLIST_FILES= bin/squidclients
do-install:
@ ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME} ${PREFIX}/bin/squidclients
diff --git a/www/squidclients/pkg-plist b/www/squidclients/pkg-plist
deleted file mode 100644
index 9ddb2b7d4761..000000000000
--- a/www/squidclients/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/squidclients
diff --git a/www/squidpurge/Makefile b/www/squidpurge/Makefile
index 74e05a6ad798..a6a1c721a188 100644
--- a/www/squidpurge/Makefile
+++ b/www/squidpurge/Makefile
@@ -20,6 +20,7 @@ COMMENT= Powerful object purging utility for the Squid web proxy cache
RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid24
+PLIST_FILES= sbin/purge
USE_GMAKE= yes
do-install:
diff --git a/www/squidpurge/pkg-plist b/www/squidpurge/pkg-plist
deleted file mode 100644
index 5b1d5d216c14..000000000000
--- a/www/squidpurge/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-sbin/purge
diff --git a/www/squidtimes/Makefile b/www/squidtimes/Makefile
index 16cb92c4fe0b..7ac49fc636c8 100644
--- a/www/squidtimes/Makefile
+++ b/www/squidtimes/Makefile
@@ -23,6 +23,7 @@ NO_WRKSUBDIR= YES
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= .
+PLIST_FILES= bin/squidtimes
do-install:
@ ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME} ${PREFIX}/bin/squidtimes
diff --git a/www/squidtimes/pkg-plist b/www/squidtimes/pkg-plist
deleted file mode 100644
index e96c0616c127..000000000000
--- a/www/squidtimes/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/squidtimes
diff --git a/www/web-traceroute/Makefile b/www/web-traceroute/Makefile
index 1c65e2363897..02f51025843d 100644
--- a/www/web-traceroute/Makefile
+++ b/www/web-traceroute/Makefile
@@ -16,6 +16,7 @@ DISTNAME= ${PORTNAME}
MAINTAINER= dean@odyssey.apana.org.au
COMMENT= WWW Traceroute CGI script written in C
+PLIST_FILES= www/cgi-bin/trace
USE_APACHE= yes
#pre-configure:
diff --git a/www/web-traceroute/pkg-plist b/www/web-traceroute/pkg-plist
deleted file mode 100644
index bb2d8408c979..000000000000
--- a/www/web-traceroute/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-www/cgi-bin/trace
diff --git a/www/webcrawl/Makefile b/www/webcrawl/Makefile
index ae266e6b90ad..b7301b5ff72e 100644
--- a/www/webcrawl/Makefile
+++ b/www/webcrawl/Makefile
@@ -19,6 +19,7 @@ COMMENT= Download web sites without user interaction by following links
ALL_TARGET=
MAN1= webcrawl.1
+PLIST_FILES= bin/webcrawl
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/webcrawl ${PREFIX}/bin/
diff --git a/www/webcrawl/pkg-plist b/www/webcrawl/pkg-plist
deleted file mode 100644
index e9b5c651ea2d..000000000000
--- a/www/webcrawl/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/webcrawl
diff --git a/www/webredirect/Makefile b/www/webredirect/Makefile
index 05a4347d5f78..a47613252f07 100644
--- a/www/webredirect/Makefile
+++ b/www/webredirect/Makefile
@@ -16,6 +16,7 @@ COMMENT= Small web server serving "301 Moved Permanently" only
ALL_TARGET= depend all
MAN1= webredirect.1
+PLIST_FILES= bin/webredirect
.include <bsd.port.pre.mk>
diff --git a/www/webredirect/pkg-plist b/www/webredirect/pkg-plist
deleted file mode 100644
index 22d1f1f8ff42..000000000000
--- a/www/webredirect/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/webredirect
diff --git a/www/wmnetselect/Makefile b/www/wmnetselect/Makefile
index b58878f442ca..d8f20db86a63 100644
--- a/www/wmnetselect/Makefile
+++ b/www/wmnetselect/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://home.att.net/~apathos/code/
MAINTAINER= nugget@slacker.com
COMMENT= WindowMaker Netscape launcher to display urls from X selection
+PLIST_FILES= bin/wmnetselect
USE_IMAKE= yes
USE_XPM= yes
diff --git a/www/wmnetselect/pkg-plist b/www/wmnetselect/pkg-plist
deleted file mode 100644
index 0879ea38433e..000000000000
--- a/www/wmnetselect/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/wmnetselect