aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Apache-SubProcess/Makefile21
-rw-r--r--www/p5-Apache-SubProcess/distinfo1
-rw-r--r--www/p5-Apache-SubProcess/pkg-comment1
-rw-r--r--www/p5-Apache-SubProcess/pkg-descr4
-rw-r--r--www/p5-Apache-SubProcess/pkg-plist7
6 files changed, 35 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 20b5f6a17f5b..f8a69acb00e1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -268,6 +268,7 @@
SUBDIR += p5-Apache-SSI
SUBDIR += p5-Apache-Session
SUBDIR += p5-Apache-Session-SharedMem
+ SUBDIR += p5-Apache-SubProcess
SUBDIR += p5-ApacheBench
SUBDIR += p5-AxKit
SUBDIR += p5-AxKit-XSP-Cookie
diff --git a/www/p5-Apache-SubProcess/Makefile b/www/p5-Apache-SubProcess/Makefile
new file mode 100644
index 000000000000..7f5aa258fe39
--- /dev/null
+++ b/www/p5-Apache-SubProcess/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: Apache-SubProcess
+# Date created: 25 October 2002
+# Whom: larse@isi.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-SubProcess
+PORTVERSION= 0.03
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= larse@isi.edu
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Apache/src.pm:${PORTSDIR}/www/mod_perl
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-SubProcess/distinfo b/www/p5-Apache-SubProcess/distinfo
new file mode 100644
index 000000000000..20d9f12ad8ad
--- /dev/null
+++ b/www/p5-Apache-SubProcess/distinfo
@@ -0,0 +1 @@
+MD5 (Apache-SubProcess-0.03.tar.gz) = 1189e0c3a02ef4bdc2707809cdf3dcc3
diff --git a/www/p5-Apache-SubProcess/pkg-comment b/www/p5-Apache-SubProcess/pkg-comment
new file mode 100644
index 000000000000..8be790026d6d
--- /dev/null
+++ b/www/p5-Apache-SubProcess/pkg-comment
@@ -0,0 +1 @@
+Forking and executing subprocesses from mod_perl
diff --git a/www/p5-Apache-SubProcess/pkg-descr b/www/p5-Apache-SubProcess/pkg-descr
new file mode 100644
index 000000000000..1c5acfb76b38
--- /dev/null
+++ b/www/p5-Apache-SubProcess/pkg-descr
@@ -0,0 +1,4 @@
+Apache::SubProcess provides the Perl API for running and communicating
+with processes spawned from mod_perl handlers.
+
+Author: Doug MacEachern
diff --git a/www/p5-Apache-SubProcess/pkg-plist b/www/p5-Apache-SubProcess/pkg-plist
new file mode 100644
index 000000000000..f2718c0db3d9
--- /dev/null
+++ b/www/p5-Apache-SubProcess/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/SubProcess/SubProcess.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/SubProcess/SubProcess.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/SubProcess/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache/SubProcess.pm
+@unexec %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/SubProcess 2>/dev/null || true
+@unexec %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache 2>/dev/null || true
+@unexec %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache 2>/dev/null || true