aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/firefox-devel/Makefile7
-rw-r--r--www/firefox-esr/Makefile7
-rw-r--r--www/firefox/Makefile7
-rw-r--r--www/firefox10/Makefile7
-rw-r--r--www/firefox15/Makefile7
-rw-r--r--www/firefox3-devel/Makefile7
-rw-r--r--www/firefox35/Makefile7
-rw-r--r--www/firefox36/Makefile7
-rw-r--r--www/flock/Makefile7
9 files changed, 63 insertions, 0 deletions
diff --git a/www/firefox-devel/Makefile b/www/firefox-devel/Makefile
index 7352b8124191..0773ad69a07c 100644
--- a/www/firefox-devel/Makefile
+++ b/www/firefox-devel/Makefile
@@ -93,6 +93,8 @@ pre-extract::
@${ECHO_MSG}
post-extract::
+# FAKEDIR is here so that nsinstall will install under FAKEDIR, not
+# under PREFIX. See pre-install and do-install for details.
@${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
-e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LDFLAGS@|${LDFLAGS}|' \
@@ -122,6 +124,9 @@ post-patch:
${WRKSRC}/calendar/sunbird/app/profile/all.js
pre-install:
+# Overview: the program installs itself in FAKEDIR, then a list is made of the
+# files and directories in there. This is the PLIST (packing list) for the
+# package, replacing the traditional pkg-plist file.
@${RM} -rf ${FAKEDIR} ${PLIST}
@${MKDIR} ${FAKEDIR}/lib/browser_plugins
@${TOUCH} ${PLIST}
@@ -148,6 +153,8 @@ pre-install:
${GREP} / >> ${PLIST}
do-install:
+# This is the actual installation. First, the contents of FAKEDIR are
+# just copied to PREFIX.
cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
post-install:
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 7352b8124191..0773ad69a07c 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -93,6 +93,8 @@ pre-extract::
@${ECHO_MSG}
post-extract::
+# FAKEDIR is here so that nsinstall will install under FAKEDIR, not
+# under PREFIX. See pre-install and do-install for details.
@${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
-e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LDFLAGS@|${LDFLAGS}|' \
@@ -122,6 +124,9 @@ post-patch:
${WRKSRC}/calendar/sunbird/app/profile/all.js
pre-install:
+# Overview: the program installs itself in FAKEDIR, then a list is made of the
+# files and directories in there. This is the PLIST (packing list) for the
+# package, replacing the traditional pkg-plist file.
@${RM} -rf ${FAKEDIR} ${PLIST}
@${MKDIR} ${FAKEDIR}/lib/browser_plugins
@${TOUCH} ${PLIST}
@@ -148,6 +153,8 @@ pre-install:
${GREP} / >> ${PLIST}
do-install:
+# This is the actual installation. First, the contents of FAKEDIR are
+# just copied to PREFIX.
cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
post-install:
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 7352b8124191..0773ad69a07c 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -93,6 +93,8 @@ pre-extract::
@${ECHO_MSG}
post-extract::
+# FAKEDIR is here so that nsinstall will install under FAKEDIR, not
+# under PREFIX. See pre-install and do-install for details.
@${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
-e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LDFLAGS@|${LDFLAGS}|' \
@@ -122,6 +124,9 @@ post-patch:
${WRKSRC}/calendar/sunbird/app/profile/all.js
pre-install:
+# Overview: the program installs itself in FAKEDIR, then a list is made of the
+# files and directories in there. This is the PLIST (packing list) for the
+# package, replacing the traditional pkg-plist file.
@${RM} -rf ${FAKEDIR} ${PLIST}
@${MKDIR} ${FAKEDIR}/lib/browser_plugins
@${TOUCH} ${PLIST}
@@ -148,6 +153,8 @@ pre-install:
${GREP} / >> ${PLIST}
do-install:
+# This is the actual installation. First, the contents of FAKEDIR are
+# just copied to PREFIX.
cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
post-install:
diff --git a/www/firefox10/Makefile b/www/firefox10/Makefile
index 7352b8124191..0773ad69a07c 100644
--- a/www/firefox10/Makefile
+++ b/www/firefox10/Makefile
@@ -93,6 +93,8 @@ pre-extract::
@${ECHO_MSG}
post-extract::
+# FAKEDIR is here so that nsinstall will install under FAKEDIR, not
+# under PREFIX. See pre-install and do-install for details.
@${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
-e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LDFLAGS@|${LDFLAGS}|' \
@@ -122,6 +124,9 @@ post-patch:
${WRKSRC}/calendar/sunbird/app/profile/all.js
pre-install:
+# Overview: the program installs itself in FAKEDIR, then a list is made of the
+# files and directories in there. This is the PLIST (packing list) for the
+# package, replacing the traditional pkg-plist file.
@${RM} -rf ${FAKEDIR} ${PLIST}
@${MKDIR} ${FAKEDIR}/lib/browser_plugins
@${TOUCH} ${PLIST}
@@ -148,6 +153,8 @@ pre-install:
${GREP} / >> ${PLIST}
do-install:
+# This is the actual installation. First, the contents of FAKEDIR are
+# just copied to PREFIX.
cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
post-install:
diff --git a/www/firefox15/Makefile b/www/firefox15/Makefile
index 7352b8124191..0773ad69a07c 100644
--- a/www/firefox15/Makefile
+++ b/www/firefox15/Makefile
@@ -93,6 +93,8 @@ pre-extract::
@${ECHO_MSG}
post-extract::
+# FAKEDIR is here so that nsinstall will install under FAKEDIR, not
+# under PREFIX. See pre-install and do-install for details.
@${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
-e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LDFLAGS@|${LDFLAGS}|' \
@@ -122,6 +124,9 @@ post-patch:
${WRKSRC}/calendar/sunbird/app/profile/all.js
pre-install:
+# Overview: the program installs itself in FAKEDIR, then a list is made of the
+# files and directories in there. This is the PLIST (packing list) for the
+# package, replacing the traditional pkg-plist file.
@${RM} -rf ${FAKEDIR} ${PLIST}
@${MKDIR} ${FAKEDIR}/lib/browser_plugins
@${TOUCH} ${PLIST}
@@ -148,6 +153,8 @@ pre-install:
${GREP} / >> ${PLIST}
do-install:
+# This is the actual installation. First, the contents of FAKEDIR are
+# just copied to PREFIX.
cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
post-install:
diff --git a/www/firefox3-devel/Makefile b/www/firefox3-devel/Makefile
index 7352b8124191..0773ad69a07c 100644
--- a/www/firefox3-devel/Makefile
+++ b/www/firefox3-devel/Makefile
@@ -93,6 +93,8 @@ pre-extract::
@${ECHO_MSG}
post-extract::
+# FAKEDIR is here so that nsinstall will install under FAKEDIR, not
+# under PREFIX. See pre-install and do-install for details.
@${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
-e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LDFLAGS@|${LDFLAGS}|' \
@@ -122,6 +124,9 @@ post-patch:
${WRKSRC}/calendar/sunbird/app/profile/all.js
pre-install:
+# Overview: the program installs itself in FAKEDIR, then a list is made of the
+# files and directories in there. This is the PLIST (packing list) for the
+# package, replacing the traditional pkg-plist file.
@${RM} -rf ${FAKEDIR} ${PLIST}
@${MKDIR} ${FAKEDIR}/lib/browser_plugins
@${TOUCH} ${PLIST}
@@ -148,6 +153,8 @@ pre-install:
${GREP} / >> ${PLIST}
do-install:
+# This is the actual installation. First, the contents of FAKEDIR are
+# just copied to PREFIX.
cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
post-install:
diff --git a/www/firefox35/Makefile b/www/firefox35/Makefile
index 7352b8124191..0773ad69a07c 100644
--- a/www/firefox35/Makefile
+++ b/www/firefox35/Makefile
@@ -93,6 +93,8 @@ pre-extract::
@${ECHO_MSG}
post-extract::
+# FAKEDIR is here so that nsinstall will install under FAKEDIR, not
+# under PREFIX. See pre-install and do-install for details.
@${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
-e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LDFLAGS@|${LDFLAGS}|' \
@@ -122,6 +124,9 @@ post-patch:
${WRKSRC}/calendar/sunbird/app/profile/all.js
pre-install:
+# Overview: the program installs itself in FAKEDIR, then a list is made of the
+# files and directories in there. This is the PLIST (packing list) for the
+# package, replacing the traditional pkg-plist file.
@${RM} -rf ${FAKEDIR} ${PLIST}
@${MKDIR} ${FAKEDIR}/lib/browser_plugins
@${TOUCH} ${PLIST}
@@ -148,6 +153,8 @@ pre-install:
${GREP} / >> ${PLIST}
do-install:
+# This is the actual installation. First, the contents of FAKEDIR are
+# just copied to PREFIX.
cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
post-install:
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index 7352b8124191..0773ad69a07c 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -93,6 +93,8 @@ pre-extract::
@${ECHO_MSG}
post-extract::
+# FAKEDIR is here so that nsinstall will install under FAKEDIR, not
+# under PREFIX. See pre-install and do-install for details.
@${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
-e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LDFLAGS@|${LDFLAGS}|' \
@@ -122,6 +124,9 @@ post-patch:
${WRKSRC}/calendar/sunbird/app/profile/all.js
pre-install:
+# Overview: the program installs itself in FAKEDIR, then a list is made of the
+# files and directories in there. This is the PLIST (packing list) for the
+# package, replacing the traditional pkg-plist file.
@${RM} -rf ${FAKEDIR} ${PLIST}
@${MKDIR} ${FAKEDIR}/lib/browser_plugins
@${TOUCH} ${PLIST}
@@ -148,6 +153,8 @@ pre-install:
${GREP} / >> ${PLIST}
do-install:
+# This is the actual installation. First, the contents of FAKEDIR are
+# just copied to PREFIX.
cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
post-install:
diff --git a/www/flock/Makefile b/www/flock/Makefile
index 7352b8124191..0773ad69a07c 100644
--- a/www/flock/Makefile
+++ b/www/flock/Makefile
@@ -93,6 +93,8 @@ pre-extract::
@${ECHO_MSG}
post-extract::
+# FAKEDIR is here so that nsinstall will install under FAKEDIR, not
+# under PREFIX. See pre-install and do-install for details.
@${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
-e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LDFLAGS@|${LDFLAGS}|' \
@@ -122,6 +124,9 @@ post-patch:
${WRKSRC}/calendar/sunbird/app/profile/all.js
pre-install:
+# Overview: the program installs itself in FAKEDIR, then a list is made of the
+# files and directories in there. This is the PLIST (packing list) for the
+# package, replacing the traditional pkg-plist file.
@${RM} -rf ${FAKEDIR} ${PLIST}
@${MKDIR} ${FAKEDIR}/lib/browser_plugins
@${TOUCH} ${PLIST}
@@ -148,6 +153,8 @@ pre-install:
${GREP} / >> ${PLIST}
do-install:
+# This is the actual installation. First, the contents of FAKEDIR are
+# just copied to PREFIX.
cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
post-install: