aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/adzap/Makefile3
-rw-r--r--www/bookmarkbridge/Makefile4
-rw-r--r--www/chtml/Makefile3
-rw-r--r--www/quickie/Makefile3
-rw-r--r--www/script4rss/Makefile3
-rw-r--r--www/xapian-omega10/Makefile3
6 files changed, 12 insertions, 7 deletions
diff --git a/www/adzap/Makefile b/www/adzap/Makefile
index f3e5cf277b7e..cd17c72670e1 100644
--- a/www/adzap/Makefile
+++ b/www/adzap/Makefile
@@ -12,8 +12,9 @@ MASTER_SITES= http://adzapper.sourceforge.net/
MAINTAINER= ports@FreeBSD.org
COMMENT= Filter out animated ad banners from web pages
+USES= perl5
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
SUB_FILES= adzap.conf pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/www/bookmarkbridge/Makefile b/www/bookmarkbridge/Makefile
index a918d4ad6141..3faccaa6f4f9 100644
--- a/www/bookmarkbridge/Makefile
+++ b/www/bookmarkbridge/Makefile
@@ -12,12 +12,12 @@ COMMENT= Synchronize bookmarks between multiple browsers
LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
-USE_PERL5_BUILD= yes
+USE_PERL5= build
USE_XORG= x11 ice xext
USE_QT4= corelib gui moc_build rcc_build uic_build qt3support
USE_GNOME= libxml2
USE_GMAKE= yes
-USES= pkgconfig
+USES= pkgconfig perl5
USE_AUTOTOOLS= aclocal automake autoconf
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing
diff --git a/www/chtml/Makefile b/www/chtml/Makefile
index 4fd770daf6a6..49bb3da84014 100644
--- a/www/chtml/Makefile
+++ b/www/chtml/Makefile
@@ -17,7 +17,8 @@ COMMENT= Chunked HTML templating engine
BUILD_DEPENDS= ${LOCALBASE}/bin/csiod:${PORTSDIR}/lang/siod
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
MAKE_ENV= SITE_PERL=${SITE_PERL}
NO_WRKSUBDIR= yes
MAKEFILE= makefile
diff --git a/www/quickie/Makefile b/www/quickie/Makefile
index 348f527352dc..7660a6a81704 100644
--- a/www/quickie/Makefile
+++ b/www/quickie/Makefile
@@ -15,7 +15,8 @@ COMMENT= Small footprint, fast Wiki engine written in C++
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --sysconfdir=${PREFIX}/etc \
--localstatedir=${DATADIR}
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
SUB_FILES= pkg-message
diff --git a/www/script4rss/Makefile b/www/script4rss/Makefile
index 67a457065026..3530f35359c0 100644
--- a/www/script4rss/Makefile
+++ b/www/script4rss/Makefile
@@ -14,8 +14,9 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Easily create scripts to convert HTML pages to RSS feeds
+USES= perl5
USE_BZIP2= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
NO_BUILD= yes
post-patch:
diff --git a/www/xapian-omega10/Makefile b/www/xapian-omega10/Makefile
index 4fa995ed43d4..28a760d2a606 100644
--- a/www/xapian-omega10/Makefile
+++ b/www/xapian-omega10/Makefile
@@ -14,9 +14,10 @@ LICENSE= GPLv2
LIB_DEPENDS= xapian:${PORTSDIR}/databases/xapian-core10
+USES= perl5
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib