aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks/kdetoys11/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-clocks/kdetoys11/Makefile')
-rw-r--r--x11-clocks/kdetoys11/Makefile23
1 files changed, 20 insertions, 3 deletions
diff --git a/x11-clocks/kdetoys11/Makefile b/x11-clocks/kdetoys11/Makefile
index fe3f229dac05..8dd7d828988a 100644
--- a/x11-clocks/kdetoys11/Makefile
+++ b/x11-clocks/kdetoys11/Makefile
@@ -5,14 +5,31 @@
# $FreeBSD$
#
-MASTERDIR= ${.CURDIR}/../../audio/kdemultimedia11-i18n
PORTNAME= kdetoys
+PORTVERSION= 1.1.2
CATEGORIES= x11-clocks kde
+MASTER_SITES= $(MASTER_SITE_KDE)
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/tar/generic/source/bz2
MAINTAINER= imura@FreeBSD.org
BUILD_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
+LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11
-.include "${MASTERDIR}/Makefile"
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_NEWGCC= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= "--with-qt-includes=${QTDIR}/include/X11/qt" \
+ "--with-extra-includes=${LOCALBASE}/include" \
+ "--with-extra-libs=${LOCALBASE}/lib"
+CONFIGURE_ENV= QTDIR=${QTDIR} \
+ DO_NOT_COMPILE=mouse
-CONFIGURE_ENV+= DO_NOT_COMPILE=mouse
+.if defined(PREFIX)
+QTDIR?= ${PREFIX}
+.else
+QTDIR?= ${X11BASE}
+.endif
+
+.include <bsd.port.mk>