aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks/kdetoys3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-clocks/kdetoys3/Makefile')
-rw-r--r--x11-clocks/kdetoys3/Makefile39
1 files changed, 12 insertions, 27 deletions
diff --git a/x11-clocks/kdetoys3/Makefile b/x11-clocks/kdetoys3/Makefile
index 3c55f0e4e6bd..5ebade465d69 100644
--- a/x11-clocks/kdetoys3/Makefile
+++ b/x11-clocks/kdetoys3/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= kdetoys
-PORTVERSION= 2.2.2
+PORTVERSION= 3.0
+PORTREVISION= 1
CATEGORIES= x11-clocks kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -14,33 +15,17 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
-BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14
-
-USE_KDELIBS_VER=2
-MOC?= ${X11BASE}/bin/moc2
+USE_KDELIBS_VER=3
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-qt-dir=${X11BASE}
-USE_GMAKE= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500029
-_NO_KDE_OBJPRELINK=yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
+USE_GMAKE= yes
-.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
-
-pre-configure:
- ${MKDIR} ${WRKSRC}/auto-bin
-.for AC in autoconf autoheader
- ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
-.endfor
-.for AM in automake aclocal
- ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
-.endfor
- cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
- ${GMAKE} -f Makefile.cvs
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>