aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks/wmfishtime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-clocks/wmfishtime/Makefile')
-rw-r--r--x11-clocks/wmfishtime/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-clocks/wmfishtime/Makefile b/x11-clocks/wmfishtime/Makefile
new file mode 100644
index 000000000000..a371c74a2537
--- /dev/null
+++ b/x11-clocks/wmfishtime/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: wmfishtime
+# Date created: 31 March 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmfishtime
+PORTVERSION= 1.1
+CATEGORIES= x11-clocks windowmaker
+MASTER_SITES= http://www.ne.jp/asahi/linux/timecop/ \
+ http://www.freenix.no/~anders/
+
+MAINTAINER= anders@fix.no
+
+USE_GTK= yes
+USE_X_PREFIX= yes
+
+pre-build:
+ ${PERL} -pi -e "s@gcc@${CC}@g; s@-O3@${CFLAGS}@g; \
+ s@gtk-config@${GTK_CONFIG}@g; s@-lgtk@-lgtk12@g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/wmfishtime ${PREFIX}/bin
+
+.include <bsd.port.mk>