aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/drm-kmod/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/drm-kmod/Makefile')
-rw-r--r--x11-drivers/drm-kmod/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-drivers/drm-kmod/Makefile b/x11-drivers/drm-kmod/Makefile
new file mode 100644
index 000000000000..b7975426eb0b
--- /dev/null
+++ b/x11-drivers/drm-kmod/Makefile
@@ -0,0 +1,32 @@
+# Created by: Jean-Sebastien Pedron <dumbbell@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= drm-kmod
+DISTVERSION= 9.280208
+CATEGORIES= x11-drivers
+MASTER_SITES= LOCAL/dumbbell
+DISTNAME= drm-${DISTVERSION}
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= FreeBSD 9.3 Kernel DRM driver
+
+LICENSE= MIT
+
+USES= tar:xz kmod
+ONLY_FOR_ARCHS= i386 amd64
+
+PLIST_FILES= ${KMODDIR}/drm2_port.ko \
+ ${KMODDIR}/i915kms_port.ko \
+ ${KMODDIR}/radeonkms_port.ko \
+
+.include <bsd.port.options.mk>
+
+.if (${OSVERSION} < 903000 || ${OSVERSION} > 1000000)
+IGNORE= this port is only for 9.3 systems
+.endif
+
+.if ${PORT_OPTIONS:MDEBUG}
+MAKE_ARGS+=" HAVE_DEBUG=YES"
+.endif
+
+.include <bsd.port.mk>