aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-ati-legacy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-ati-legacy/Makefile')
-rw-r--r--x11-drivers/xf86-video-ati-legacy/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-ati-legacy/Makefile b/x11-drivers/xf86-video-ati-legacy/Makefile
new file mode 100644
index 000000000000..fd55138e6b79
--- /dev/null
+++ b/x11-drivers/xf86-video-ati-legacy/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= xf86-video-ati-legacy
+PORTVERSION= 7.9.0
+PORTREVISION= 3
+PORTEPOCH= 1
+CATEGORIES= x11-drivers
+DISTNAME= xf86-video-ati-${DISTVERSION}
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X.Org ati display driver
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libpciaccess.so:devel/libpciaccess \
+ libdrm_radeon.so:graphics/libdrm
+
+CONFLICTS_INSTALL= xf86-video-ati
+
+USE_GL= gl
+XORG_CAT= driver
+USE_XORG= pciaccess
+
+# No Radeon kernel driver on non-x86 and PC98.
+ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS_REASON= KMS is required and currently only available on x86
+
+CONFIGURE_ARGS+=--disable-udev
+
+.include <bsd.port.mk>