aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-mga/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-mga/Makefile')
-rw-r--r--x11-drivers/xf86-video-mga/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-mga/Makefile b/x11-drivers/xf86-video-mga/Makefile
new file mode 100644
index 000000000000..e4ec426b464e
--- /dev/null
+++ b/x11-drivers/xf86-video-mga/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xf86-video-mga
+# Date Created: 17 Feb 2006
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xf86-video-mga
+PORTVERSION= 1.4.6.1
+PORTREVISION= 1
+CATEGORIES= x11-drivers
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X.Org mga display driver
+
+USE_GL= gl
+
+XORG_CAT= driver
+USE_XORG= xf86driproto videoproto xextproto glproto
+MAN4= mga.4x
+USE_REINPLACE= yes
+
+pre-patch:
+ ${REINPLACE_CMD} \
+ -e 's|values.h|sys/limits.h|g' \
+ -e 's|MAXSHORT|SHRT_MAX|g' \
+ ${WRKSRC}/src/mga_arc.c
+
+.include <bsd.port.mk>