aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-newport/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-newport/Makefile')
-rw-r--r--x11-drivers/xf86-video-newport/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-newport/Makefile b/x11-drivers/xf86-video-newport/Makefile
new file mode 100644
index 000000000000..71d9006f9326
--- /dev/null
+++ b/x11-drivers/xf86-video-newport/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: xf86-video-newport
+# Date Created: 17 Feb 2006
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xf86-video-newport
+PORTVERSION= 0.2.1
+CATEGORIES= x11-drivers
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X.Org newport display driver
+
+XORG_CAT= driver
+USE_XORG= videoproto
+MAN4= newport.4x
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|values.h|sys/limits.h|' \
+ -e 's|MAXSHORT|SHRT_MAX|g' \
+ ${WRKSRC}/src/newport_accel.c
+
+.include <bsd.port.mk>