aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-radeonhd-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-radeonhd-devel/Makefile')
-rw-r--r--x11-drivers/xf86-video-radeonhd-devel/Makefile23
1 files changed, 21 insertions, 2 deletions
diff --git a/x11-drivers/xf86-video-radeonhd-devel/Makefile b/x11-drivers/xf86-video-radeonhd-devel/Makefile
index 63b1e12485ad..357b6d6ca8b5 100644
--- a/x11-drivers/xf86-video-radeonhd-devel/Makefile
+++ b/x11-drivers/xf86-video-radeonhd-devel/Makefile
@@ -6,15 +6,34 @@
#
PORTNAME= xf86-video-radeonhd
-PORTVERSION= 1.2.0
+PORTVERSION= 1.2.1
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
COMMENT= X.Org ati RadeonHD display driver
+OPTIONS= UTILS "Install rhd_conntest and rhd_dump utilities" off
+
XORG_CAT= driver
USE_XORG= videoproto xextproto
MAN4= radeonhd.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_UTILS)
+LIB_DEPENDS+= pci.2:${PORTSDIR}/devel/libpci
+PLIST_SUB= UTILS=""
+CONFIGURE_ENV+= PCIUTILS_CFLAGS="-I${LOCALBASE}/include -lpci -lz" \
+ PCIUTILS_LIBS="-L${LOCALBASE}/lib"
+.else
+PLIST_SUB= UTILS="@comment "
+.endif
+
+.if defined(WITH_UTILS)
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/utils/conntest/rhd_conntest ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/utils/conntest/rhd_dump ${PREFIX}/sbin
+.endif
+
+.include <bsd.port.post.mk>