aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/FSViewer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/FSViewer/Makefile')
-rw-r--r--x11-fm/FSViewer/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/x11-fm/FSViewer/Makefile b/x11-fm/FSViewer/Makefile
index e0bce841e2f1..2256a9df73cf 100644
--- a/x11-fm/FSViewer/Makefile
+++ b/x11-fm/FSViewer/Makefile
@@ -7,21 +7,27 @@
PORTNAME= FSViewer.app
PORTVERSION= 0.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-fm windowmaker
MASTER_SITES= http://www.bayernline.de/~gscholz/linux/fsviewer/
-DISTNAME= FSViewer.app-${PORTVERSION}
+
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= ${PORTNAME}-${PORTVERSION}-WM-0.81.0.patch.gz
+PATCH_DIST_STRIP= -p1
MAINTAINER= Fritz.Heinrichmeyer@fernuni-hagen.de
COMMENT= X11 file manager using WINGS library. Dockable in WindowMaker
-BROKEN= "Does not build with new version of windowmaker"
-
LIB_DEPENDS= wraster.4:${PORTSDIR}/x11-wm/windowmaker
-GNU_CONFIGURE= yes
USE_X_PREFIX= yes
-USE_GMAKE=yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS= `pkg-config --cflags WINGs`
+LDFLAGS= `pkg-config --libs WINGs`
post-install:
${MKDIR} ${PREFIX}/share/doc/FSViewer