aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/nautilus2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/nautilus2/Makefile')
-rw-r--r--x11-fm/nautilus2/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-fm/nautilus2/Makefile b/x11-fm/nautilus2/Makefile
index afa493d0180f..1e872d0c3f4e 100644
--- a/x11-fm/nautilus2/Makefile
+++ b/x11-fm/nautilus2/Makefile
@@ -33,7 +33,7 @@ USE_GNOME= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -fno-rtti -fno-exceptions" \
- LIBS="-pthread -L${LOCALBASE}/lib" \
+ LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib" \
LIBPNG="-L${LOCALBASE}/lib -lpng -lz ${MOZILLA_LIBS}"
CONFIGURE_ARGS= --with-freetype2-lib-place=${LOCALBASE}/lib \
--with-freetype2-include-place=${LOCALBASE}/include/freetype2
@@ -55,7 +55,7 @@ pre-extract:
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \