aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/rodent/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/rodent/Makefile')
-rw-r--r--x11-fm/rodent/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-fm/rodent/Makefile b/x11-fm/rodent/Makefile
index dc243857b039..58c1ce304a4e 100644
--- a/x11-fm/rodent/Makefile
+++ b/x11-fm/rodent/Makefile
@@ -47,4 +47,10 @@ post-patch:
${REINPLACE_CMD} -e 's,^\(docdir = \).*,\1${DOCSDIR},' \
${WRKSRC}/Build/share/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
+.endif
+
+.include <bsd.port.post.mk>