aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/rox-filer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/rox-filer/Makefile')
-rw-r--r--x11-fm/rox-filer/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/x11-fm/rox-filer/Makefile b/x11-fm/rox-filer/Makefile
index 03054fe2d5e9..292564e33236 100644
--- a/x11-fm/rox-filer/Makefile
+++ b/x11-fm/rox-filer/Makefile
@@ -21,17 +21,27 @@ RUN_DEPENDS= ${LOCALBASE}/share/mime/packages/freedesktop.org.xml:${PORTSDIR}/mi
MAN1= rox.1
+.include <bsd.port.pre.mk>
+
do-build:
# Run the custom build procedure
cd ${WRKSRC} && GTK_CONFIG=${GTK_CONFIG} GLIB_CONFIG=${GLIB_CONFIG} ROX-Filer/AppRun --compile
+.if (${ARCH} == "i386")
+BINARIES= FreeBSD-ix86
+.else
+BINARIES= FreeBSD-${ARCH}
+.endif
+
+PLIST_SUB= BINARIES="${BINARIES}"
+
do-install:
${MKDIR} ${PREFIX}/apps/ROX-Filer
- cd ${WRKSRC}/ROX-Filer && ${CP} -r .DirIcon Action.png AppInfo.xml AppRun FreeBSD-ix86 Help Messages Options.xml images style.css ${PREFIX}/apps/ROX-Filer
+ cd ${WRKSRC}/ROX-Filer && ${CP} -r .DirIcon Action.png AppInfo.xml AppRun ${BINARIES} Help Messages Options.xml images style.css ${PREFIX}/apps/ROX-Filer
cd ${WRKSRC} && ${CP} -r Choices ${PREFIX}/share/
${MKDIR} ${PREFIX}/share/mime/mime-info
${CAT} ${FILESDIR}/rox | ${SED} -e "s|%%PREFIX%%|${PREFIX}|" > ${PREFIX}/bin/rox
${CHMOD} 775 ${PREFIX}/bin/rox
${INSTALL_MAN} ${WRKSRC}/rox.1 ${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>