aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/sushi
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/sushi')
-rw-r--r--x11-fm/sushi/Makefile32
-rw-r--r--x11-fm/sushi/distinfo2
-rw-r--r--x11-fm/sushi/pkg-descr3
-rw-r--r--x11-fm/sushi/pkg-plist88
4 files changed, 125 insertions, 0 deletions
diff --git a/x11-fm/sushi/Makefile b/x11-fm/sushi/Makefile
new file mode 100644
index 000000000000..76dcc5b75b66
--- /dev/null
+++ b/x11-fm/sushi/Makefile
@@ -0,0 +1,32 @@
+# Created by: Gustau Perez i Querol <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/x11-fm/sushi/Makefile 19578 2014-04-25 21:50:30Z kwm $
+
+PORTNAME= sushi
+PORTVERSION= 3.12.0
+CATEGORIES= x11-fm gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Tool similar to Gloobus Preview that provides quick file previews
+
+LIB_DEPENDS= libgcr-3.so:${PORTSDIR}/security/gcr \
+ libgjs.so:${PORTSDIR}/lang/gjs \
+ libclutter-gtk-1.0.so:${PORTSDIR}/graphics/clutter-gtk3 \
+ libclutter-gst-2.0.so:${PORTSDIR}/multimedia/clutter-gst \
+ libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3 \
+ libmusicbrainz5.so:${PORTSDIR}/audio/libmusicbrainz5 \
+ libevdocument3.so:${PORTSDIR}/graphics/evince
+RUN_DEPENDS= nautilus:${PORTSDIR}/x11-fm/nautilus
+
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
+INSTALLS_ICONS= yes
+USE_GNOME= gnomeprefix gtksourceview3 intlhack introspection:build
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>
diff --git a/x11-fm/sushi/distinfo b/x11-fm/sushi/distinfo
new file mode 100644
index 000000000000..1148ec23d919
--- /dev/null
+++ b/x11-fm/sushi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/sushi-3.12.0.tar.xz) = 78594a858371b671671205e7b2518e7eb82ed8c2540b62f45a657aaabdf1a9ff
+SIZE (gnome3/sushi-3.12.0.tar.xz) = 281976
diff --git a/x11-fm/sushi/pkg-descr b/x11-fm/sushi/pkg-descr
new file mode 100644
index 000000000000..c41bda32ca0f
--- /dev/null
+++ b/x11-fm/sushi/pkg-descr
@@ -0,0 +1,3 @@
+Sushi is a new GNOME 3.2 tool similar to Gloobus Preview that provides quick file previews.
+
+WWW: http://www.ubuntugeek.com/gnome-sushi-quick-previewer-for-nautilus.html
diff --git a/x11-fm/sushi/pkg-plist b/x11-fm/sushi/pkg-plist
new file mode 100644
index 000000000000..d372db411841
--- /dev/null
+++ b/x11-fm/sushi/pkg-plist
@@ -0,0 +1,88 @@
+bin/sushi
+lib/sushi/girepository-1.0/Sushi-1.0.typelib
+lib/sushi/libsushi-1.0.so
+libexec/sushi-start
+share/dbus-1/services/org.gnome.Sushi.service
+share/glib-2.0/schemas/org.gnome.sushi.gschema.xml
+share/locale/an/LC_MESSAGES/sushi.mo
+share/locale/ar/LC_MESSAGES/sushi.mo
+share/locale/as/LC_MESSAGES/sushi.mo
+share/locale/ast/LC_MESSAGES/sushi.mo
+share/locale/be/LC_MESSAGES/sushi.mo
+share/locale/bg/LC_MESSAGES/sushi.mo
+share/locale/bn_IN/LC_MESSAGES/sushi.mo
+share/locale/ca/LC_MESSAGES/sushi.mo
+share/locale/ca@valencia/LC_MESSAGES/sushi.mo
+share/locale/cs/LC_MESSAGES/sushi.mo
+share/locale/da/LC_MESSAGES/sushi.mo
+share/locale/de/LC_MESSAGES/sushi.mo
+share/locale/el/LC_MESSAGES/sushi.mo
+share/locale/en_GB/LC_MESSAGES/sushi.mo
+share/locale/eo/LC_MESSAGES/sushi.mo
+share/locale/es/LC_MESSAGES/sushi.mo
+share/locale/et/LC_MESSAGES/sushi.mo
+share/locale/eu/LC_MESSAGES/sushi.mo
+share/locale/fa/LC_MESSAGES/sushi.mo
+share/locale/fi/LC_MESSAGES/sushi.mo
+share/locale/fr/LC_MESSAGES/sushi.mo
+share/locale/fur/LC_MESSAGES/sushi.mo
+share/locale/gl/LC_MESSAGES/sushi.mo
+share/locale/gu/LC_MESSAGES/sushi.mo
+share/locale/he/LC_MESSAGES/sushi.mo
+share/locale/hi/LC_MESSAGES/sushi.mo
+share/locale/hu/LC_MESSAGES/sushi.mo
+share/locale/id/LC_MESSAGES/sushi.mo
+share/locale/it/LC_MESSAGES/sushi.mo
+share/locale/ja/LC_MESSAGES/sushi.mo
+share/locale/kn/LC_MESSAGES/sushi.mo
+share/locale/ko/LC_MESSAGES/sushi.mo
+share/locale/lt/LC_MESSAGES/sushi.mo
+share/locale/lv/LC_MESSAGES/sushi.mo
+share/locale/ml/LC_MESSAGES/sushi.mo
+share/locale/mr/LC_MESSAGES/sushi.mo
+share/locale/nb/LC_MESSAGES/sushi.mo
+share/locale/nl/LC_MESSAGES/sushi.mo
+share/locale/or/LC_MESSAGES/sushi.mo
+share/locale/pa/LC_MESSAGES/sushi.mo
+share/locale/pl/LC_MESSAGES/sushi.mo
+share/locale/pt/LC_MESSAGES/sushi.mo
+share/locale/pt_BR/LC_MESSAGES/sushi.mo
+share/locale/ru/LC_MESSAGES/sushi.mo
+share/locale/sk/LC_MESSAGES/sushi.mo
+share/locale/sl/LC_MESSAGES/sushi.mo
+share/locale/sr/LC_MESSAGES/sushi.mo
+share/locale/sr@latin/LC_MESSAGES/sushi.mo
+share/locale/sv/LC_MESSAGES/sushi.mo
+share/locale/ta/LC_MESSAGES/sushi.mo
+share/locale/te/LC_MESSAGES/sushi.mo
+share/locale/tg/LC_MESSAGES/sushi.mo
+share/locale/th/LC_MESSAGES/sushi.mo
+share/locale/tr/LC_MESSAGES/sushi.mo
+share/locale/ug/LC_MESSAGES/sushi.mo
+share/locale/uk/LC_MESSAGES/sushi.mo
+share/locale/uz@cyrillic/LC_MESSAGES/sushi.mo
+share/locale/vi/LC_MESSAGES/sushi.mo
+share/locale/zh_CN/LC_MESSAGES/sushi.mo
+share/locale/zh_HK/LC_MESSAGES/sushi.mo
+share/locale/zh_TW/LC_MESSAGES/sushi.mo
+share/sushi/gir-1.0/Sushi-1.0.gir
+share/sushi/js/ui/application.js
+share/sushi/js/ui/fallbackRenderer.js
+share/sushi/js/ui/main.js
+share/sushi/js/ui/mainWindow.js
+share/sushi/js/ui/mimeHandler.js
+share/sushi/js/ui/spinnerBox.js
+share/sushi/js/ui/tweener.js
+share/sushi/js/ui/utils.js
+share/sushi/js/util/constants.js
+share/sushi/js/util/format.js
+share/sushi/js/util/path.js
+share/sushi/js/util/totemMimeTypes.js
+share/sushi/js/viewers/audio.js
+share/sushi/js/viewers/evince.js
+share/sushi/js/viewers/font.js
+share/sushi/js/viewers/gst.js
+share/sushi/js/viewers/html.js
+share/sushi/js/viewers/image.js
+share/sushi/js/viewers/text.js
+share/sushi/style/gtk-style.css