aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/doublecmd/Makefile2
-rw-r--r--x11-fm/doublecmd/files/patch-components_multithreadprocs_mtpcpu.pas22
2 files changed, 23 insertions, 1 deletions
diff --git a/x11-fm/doublecmd/Makefile b/x11-fm/doublecmd/Makefile
index 234172073bc1..55304c4b76d3 100644
--- a/x11-fm/doublecmd/Makefile
+++ b/x11-fm/doublecmd/Makefile
@@ -25,7 +25,7 @@ USE_FPC= cairo chm fcl-base fcl-db fcl-image fcl-json fcl-registry \
fcl-xml iconvenc pasjpeg rtl-extra x11 regexpr
USE_GNOME= cairo glib20
USE_XORG= x11
-DOS2UNIX_FILES= src/dmhelpmanager.pas
+DOS2UNIX_FILES= src/dmhelpmanager.pas components/multithreadprocs/mtpcpu.pas
PLIST= ${WRKDIR}/pkg-plist
diff --git a/x11-fm/doublecmd/files/patch-components_multithreadprocs_mtpcpu.pas b/x11-fm/doublecmd/files/patch-components_multithreadprocs_mtpcpu.pas
new file mode 100644
index 000000000000..db3dc06a4aba
--- /dev/null
+++ b/x11-fm/doublecmd/files/patch-components_multithreadprocs_mtpcpu.pas
@@ -0,0 +1,22 @@
+--- components/multithreadprocs/mtpcpu.pas.orig 2015-09-06 12:19:32 UTC
++++ components/multithreadprocs/mtpcpu.pas
+@@ -69,15 +69,17 @@ end;
+ t = sysconf(_SC_NPROC_ONLN);
+ end;
+ {$ELSEIF defined(freebsd) or defined(darwin)}
++type
++ PSysCtl = {$IF FPC_FULLVERSION>=30200}pcint{$ELSE}pchar{$ENDIF};
+ var
+ mib: array[0..1] of cint;
+- len: cint;
++ len: csize_t;
+ t: cint;
+ begin
+ mib[0] := CTL_HW;
+ mib[1] := HW_NCPU;
+ len := sizeof(t);
+- fpsysctl(pchar(@mib), 2, @t, @len, Nil, 0);
++ fpsysctl(PSysCtl(@mib), 2, @t, @len, Nil, 0);
+ Result:=t;
+ end;
+ {$ELSEIF defined(linux)}