aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/fontconfig
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/fontconfig')
-rw-r--r--x11-fonts/fontconfig/Makefile6
-rw-r--r--x11-fonts/fontconfig/distinfo6
-rw-r--r--x11-fonts/fontconfig/files/patch-fc-git80
-rw-r--r--x11-fonts/fontconfig/pkg-plist13
4 files changed, 13 insertions, 92 deletions
diff --git a/x11-fonts/fontconfig/Makefile b/x11-fonts/fontconfig/Makefile
index fd220265f2b4..124d2641e289 100644
--- a/x11-fonts/fontconfig/Makefile
+++ b/x11-fonts/fontconfig/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11-fonts/fontconfig/Makefile,v 1.12 2007/02/02 19:49:43 mezz Exp $
+# $MCom: ports/x11-fonts/fontconfig/Makefile,v 1.14 2008/01/08 04:28:10 marcus Exp $
#
PORTNAME= fontconfig
-PORTVERSION= 2.4.2
-PORTREVISION?= 2
+PORTVERSION= 2.5.0
+PORTREVISION?= 0
PORTEPOCH?= 1
CATEGORIES= x11-fonts
MASTER_SITES= http://fontconfig.org/release/
diff --git a/x11-fonts/fontconfig/distinfo b/x11-fonts/fontconfig/distinfo
index 25c81d9673e9..0687fa08ca78 100644
--- a/x11-fonts/fontconfig/distinfo
+++ b/x11-fonts/fontconfig/distinfo
@@ -1,3 +1,3 @@
-MD5 (fontconfig-2.4.2.tar.gz) = f035852f521b54677f2b5c9e2f6d54a4
-SHA256 (fontconfig-2.4.2.tar.gz) = 63a3d6413182817b91eea327b58c243f1865acfc40bef61fc52d2b0431341363
-SIZE (fontconfig-2.4.2.tar.gz) = 1278340
+MD5 (fontconfig-2.5.0.tar.gz) = 21d14af8ecf645ef76211c782cdd7aeb
+SHA256 (fontconfig-2.5.0.tar.gz) = 34c6badb4cb7eb496779d30616903de400fa244838ea39c2a7f63eaa5fdf0efe
+SIZE (fontconfig-2.5.0.tar.gz) = 1385058
diff --git a/x11-fonts/fontconfig/files/patch-fc-git b/x11-fonts/fontconfig/files/patch-fc-git
deleted file mode 100644
index d0be05b24e8a..000000000000
--- a/x11-fonts/fontconfig/files/patch-fc-git
+++ /dev/null
@@ -1,80 +0,0 @@
---- src/fcfreetype.c.orig Sat Apr 14 01:46:21 2007
-+++ src/fcfreetype.c Sat Apr 14 01:48:33 2007
-@@ -2413,6 +2413,19 @@ FcGlyphNameToUcs4 (FcChar8 *name)
- }
-
- /*
-+* Work around a bug in some FreeType versions which fail
-+* to correctly bounds check glyph name buffers and overwrite
-+* the stack. As Postscript names have a limit of 127 characters,
-+* this should be sufficient.
-+*/
-+
-+#if FC_GLYPHNAME_MAXLEN < 127
-+# define FC_GLYPHNAME_BUFLEN 127
-+#else
-+# define FC_GLYPHNAME_BUFLEN FC_GLYPHNAME_MAXLEN
-+#endif
-+
-+/*
- * Search through a font for a glyph by name. This is
- * currently a linear search as there doesn't appear to be
- * any defined order within the font
-@@ -2421,11 +2434,11 @@ static FT_UInt
- FcFreeTypeGlyphNameIndex (FT_Face face, const FcChar8 *name)
- {
- FT_UInt gindex;
-- FcChar8 name_buf[FC_GLYPHNAME_MAXLEN + 2];
-+ FcChar8 name_buf[FC_GLYPHNAME_BUFLEN + 2];
-
- for (gindex = 0; gindex < (FT_UInt) face->num_glyphs; gindex++)
- {
-- if (FT_Get_Glyph_Name (face, gindex, name_buf, FC_GLYPHNAME_MAXLEN+1) == 0)
-+ if (FT_Get_Glyph_Name (face, gindex, name_buf, FC_GLYPHNAME_BUFLEN+1) == 0)
- if (!strcmp ((char *) name, (char *) name_buf))
- return gindex;
- }
-@@ -2715,11 +2728,11 @@ FcFreeTypeCharSetAndSpacing (FT_Face fac
- */
- if (FcFreeTypeUseNames (face))
- {
-- FcChar8 name_buf[FC_GLYPHNAME_MAXLEN + 2];
-+ FcChar8 name_buf[FC_GLYPHNAME_BUFLEN + 2];
-
- for (glyph = 0; glyph < (FT_UInt) face->num_glyphs; glyph++)
- {
-- if (FT_Get_Glyph_Name (face, glyph, name_buf, FC_GLYPHNAME_MAXLEN+1) == 0)
-+ if (FT_Get_Glyph_Name (face, glyph, name_buf, FC_GLYPHNAME_BUFLEN+1) == 0)
- {
- ucs4 = FcGlyphNameToUcs4 (name_buf);
- if (ucs4 != 0xffff &&
---- fc-glyphname/fc-glyphname.c.orig Sat Apr 14 01:49:42 2007
-+++ fc-glyphname/fc-glyphname.c Sat Apr 14 01:49:55 2007
-@@ -206,7 +206,7 @@ insert (FcGlyphName *gn, FcGlyphName **t
- i = (int) (h % hash);
- while (table[i])
- {
-- if (!r) r = (int) (h % rehash);
-+ if (!r) r = (int) (h % rehash + 1);
- i += r;
- if (i >= hash)
- i -= hash;
---- src/fcpat.c.orig Sat Apr 14 01:51:00 2007
-+++ src/fcpat.c Sat Apr 14 01:52:23 2007
-@@ -925,10 +925,13 @@ FcPatternDuplicate (const FcPattern *ori
- for (i = 0; i < orig->num; i++)
- {
- for (l = FcPatternEltValues(e + i); l; l = FcValueListNext(l))
-- if (!FcPatternObjectAdd (new, e[i].object,
-- FcValueCanonicalize(&l->value),
-- FcTrue))
-+ {
-+ if (!FcPatternObjectAddWithBinding (new, e[i].object,
-+ FcValueCanonicalize(&l->value),
-+ l->binding,
-+ FcTrue))
- goto bail1;
-+ }
- }
-
- return new;
diff --git a/x11-fonts/fontconfig/pkg-plist b/x11-fonts/fontconfig/pkg-plist
index 05f221ba92eb..46bba932d100 100644
--- a/x11-fonts/fontconfig/pkg-plist
+++ b/x11-fonts/fontconfig/pkg-plist
@@ -10,11 +10,12 @@ etc/fonts/conf.avail/10-sub-pixel-vbgr.conf
etc/fonts/conf.avail/10-sub-pixel-vrgb.conf
etc/fonts/conf.avail/10-unhinted.conf
etc/fonts/conf.avail/20-fix-globaladvance.conf
-etc/fonts/conf.avail/20-lohit-gujarati.conf
etc/fonts/conf.avail/20-unhint-small-vera.conf
-etc/fonts/conf.avail/30-amt-aliases.conf
+etc/fonts/conf.avail/25-unhint-nonlatin.conf
+etc/fonts/conf.avail/30-metric-aliases.conf
etc/fonts/conf.avail/30-urw-aliases.conf
-etc/fonts/conf.avail/40-generic.conf
+etc/fonts/conf.avail/40-nonlatin.conf
+etc/fonts/conf.avail/45-latin.conf
etc/fonts/conf.avail/49-sansserif.conf
etc/fonts/conf.avail/50-user.conf
etc/fonts/conf.avail/51-local.conf
@@ -28,11 +29,11 @@ etc/fonts/conf.avail/80-delicious.conf
etc/fonts/conf.avail/90-synthetic.conf
etc/fonts/conf.avail/README
etc/fonts/conf.d/20-fix-globaladvance.conf
-etc/fonts/conf.d/20-lohit-gujarati.conf
etc/fonts/conf.d/20-unhint-small-vera.conf
-etc/fonts/conf.d/30-amt-aliases.conf
+etc/fonts/conf.d/30-metric-aliases.conf
etc/fonts/conf.d/30-urw-aliases.conf
-etc/fonts/conf.d/40-generic.conf
+etc/fonts/conf.d/40-nonlatin.conf
+etc/fonts/conf.d/45-latin.conf
etc/fonts/conf.d/49-sansserif.conf
etc/fonts/conf.d/50-user.conf
etc/fonts/conf.d/51-local.conf