aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/fonts-indic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/fonts-indic/Makefile')
-rw-r--r--x11-fonts/fonts-indic/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-fonts/fonts-indic/Makefile b/x11-fonts/fonts-indic/Makefile
new file mode 100644
index 000000000000..221013af0805
--- /dev/null
+++ b/x11-fonts/fonts-indic/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: fonts-indic
+# Date created: 19 Septenber 2007
+# Whom: Naresh Venkateshappa <nareshov@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fonts-indic
+PORTVERSION= 2.1.5
+CATEGORIES= x11-fonts
+MASTER_SITES= http://gentoo.osuosl.org/distfiles/
+
+MAINTAINER= nareshov@gmail.com
+COMMENT= The Lohit family of Indic fonts
+
+RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
+
+USE_GZIP= yes
+USE_X_PREFIX= yes
+NO_BUILD= yes
+
+NO_WRKSUBDIR= yes
+FONTSDIR= lib/X11/fonts/${PORTNAME}/
+PLIST_SUB+= FONTSDIR=${FONTSDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*/*/*.ttf ${PREFIX}/${FONTSDIR}
+
+post-install:
+ @${ECHO_MSG} "==> Running fc-cache"
+ @${X11BASE}/bin/fc-cache -f -v ${PREFIX}/${FONTSDIR}
+
+.include <bsd.port.mk>