aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/linux-c6-fontconfig/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/linux-c6-fontconfig/Makefile')
-rw-r--r--x11-fonts/linux-c6-fontconfig/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-fonts/linux-c6-fontconfig/Makefile b/x11-fonts/linux-c6-fontconfig/Makefile
new file mode 100644
index 000000000000..4d55c6064b07
--- /dev/null
+++ b/x11-fonts/linux-c6-fontconfig/Makefile
@@ -0,0 +1,35 @@
+# Created by: Artyom Mirgorodskiy <artyom.mirgorodsky@gmail.com>
+# $FreeBSD$
+
+PORTNAME= fontconfig
+PORTVERSION= 2.8.0
+CATEGORIES= x11-fonts linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= XML-based font configuration API for X Windows (Linux CentOS ${LINUX_DIST_VER})
+
+CONFLICTS= linux-fontconfig-[0-9]* linux-f8-fontconfig-[0-9]* linux-f10-fontconfig-[0-9]*
+
+ONLY_FOR_ARCHS= i386 amd64
+RPMVERSION= 3.el6
+USE_LINUX= c6
+USE_LINUX_APPS= expat
+
+USE_LINUX_RPM= yes
+BRANDELF_DIRS= usr/bin
+USE_LDCONFIG= yes
+
+# We will use some other configuration file, so delete a linux one
+# Don't let the linux fc-cache mess up the native cache file
+post-extract:
+ @${RM} -r ${WRKSRC}/etc ${WRKSRC}/usr/share/fonts ${WRKSRC}/var \
+ ${WRKSRC}/usr/bin/fc-cache \
+ ${WRKSRC}/usr/share/man/man1/fc-cache.1.gz
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc
+ @${LN} -s ${LOCALBASE}/etc/fonts ${STAGEDIR}${PREFIX}/etc/
+
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>