aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/linux-c6-fontconfig
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/linux-c6-fontconfig')
-rw-r--r--x11-fonts/linux-c6-fontconfig/Makefile35
-rw-r--r--x11-fonts/linux-c6-fontconfig/distinfo.i6864
-rw-r--r--x11-fonts/linux-c6-fontconfig/pkg-descr22
-rw-r--r--x11-fonts/linux-c6-fontconfig/pkg-plist22
4 files changed, 83 insertions, 0 deletions
diff --git a/x11-fonts/linux-c6-fontconfig/Makefile b/x11-fonts/linux-c6-fontconfig/Makefile
new file mode 100644
index 000000000000..4d55c6064b07
--- /dev/null
+++ b/x11-fonts/linux-c6-fontconfig/Makefile
@@ -0,0 +1,35 @@
+# Created by: Artyom Mirgorodskiy <artyom.mirgorodsky@gmail.com>
+# $FreeBSD$
+
+PORTNAME= fontconfig
+PORTVERSION= 2.8.0
+CATEGORIES= x11-fonts linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= XML-based font configuration API for X Windows (Linux CentOS ${LINUX_DIST_VER})
+
+CONFLICTS= linux-fontconfig-[0-9]* linux-f8-fontconfig-[0-9]* linux-f10-fontconfig-[0-9]*
+
+ONLY_FOR_ARCHS= i386 amd64
+RPMVERSION= 3.el6
+USE_LINUX= c6
+USE_LINUX_APPS= expat
+
+USE_LINUX_RPM= yes
+BRANDELF_DIRS= usr/bin
+USE_LDCONFIG= yes
+
+# We will use some other configuration file, so delete a linux one
+# Don't let the linux fc-cache mess up the native cache file
+post-extract:
+ @${RM} -r ${WRKSRC}/etc ${WRKSRC}/usr/share/fonts ${WRKSRC}/var \
+ ${WRKSRC}/usr/bin/fc-cache \
+ ${WRKSRC}/usr/share/man/man1/fc-cache.1.gz
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc
+ @${LN} -s ${LOCALBASE}/etc/fonts ${STAGEDIR}${PREFIX}/etc/
+
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/linux-c6-fontconfig/distinfo.i686 b/x11-fonts/linux-c6-fontconfig/distinfo.i686
new file mode 100644
index 000000000000..dee88fe55537
--- /dev/null
+++ b/x11-fonts/linux-c6-fontconfig/distinfo.i686
@@ -0,0 +1,4 @@
+SHA256 (rpm/i686/centos/6.5/fontconfig-2.8.0-3.el6.i686.rpm) = 86730c2bebd675c9fec8856c54112a18371eff52a307f88534800b3c844e729f
+SIZE (rpm/i686/centos/6.5/fontconfig-2.8.0-3.el6.i686.rpm) = 190816
+SHA256 (rpm/i686/centos/6.5/fontconfig-2.8.0-3.el6.src.rpm) = aac3289c48c430f1b563af790084c893d622ae58559923d9c7a35712606b6fb9
+SIZE (rpm/i686/centos/6.5/fontconfig-2.8.0-3.el6.src.rpm) = 1563078
diff --git a/x11-fonts/linux-c6-fontconfig/pkg-descr b/x11-fonts/linux-c6-fontconfig/pkg-descr
new file mode 100644
index 000000000000..6ba73f488307
--- /dev/null
+++ b/x11-fonts/linux-c6-fontconfig/pkg-descr
@@ -0,0 +1,22 @@
+This is a Linux/i386 binary port of the Fontconfig library and utilities.
+
+In the words of its author, Keith Packard:
+
+ Fontconfig can:
+ * discover new fonts when installed automatically, removing a common
+ source of configuration problems.
+ * perform font name substitution, so that appropriate alternative
+ fonts can be selected if fonts are missing.
+ * identify the set of fonts required to completely cover a set of
+ languages.
+ * have GUI configuration tools built as it uses an XML-based
+ configuration file (though with autodiscovery, we believe this need
+ is minimized).
+ * efficiently and quickly find the fonts you need among the set of
+ fonts you have installed, even if you have installed thousands of
+ fonts, while minimzing memory usage.
+ * be used in concert with the X Render Extension and FreeType to
+ implement high quality, anti-aliased and subpixel rendered text on a
+ display.
+
+WWW: http://freedesktop.org/software/fontconfig
diff --git a/x11-fonts/linux-c6-fontconfig/pkg-plist b/x11-fonts/linux-c6-fontconfig/pkg-plist
new file mode 100644
index 000000000000..abae0f054888
--- /dev/null
+++ b/x11-fonts/linux-c6-fontconfig/pkg-plist
@@ -0,0 +1,22 @@
+@comment file listing
+etc/fonts
+usr/bin/fc-cat
+usr/bin/fc-list
+usr/bin/fc-match
+usr/bin/fc-query
+usr/bin/fc-scan
+usr/lib/libfontconfig.so.1
+usr/lib/libfontconfig.so.1.4.4
+usr/share/doc/fontconfig-2.8.0/AUTHORS
+usr/share/doc/fontconfig-2.8.0/COPYING
+usr/share/doc/fontconfig-2.8.0/README
+usr/share/doc/fontconfig-2.8.0/fontconfig-user.html
+usr/share/doc/fontconfig-2.8.0/fontconfig-user.txt
+usr/share/man/man1/fc-cat.1.gz
+usr/share/man/man1/fc-list.1.gz
+usr/share/man/man1/fc-match.1.gz
+usr/share/man/man1/fc-query.1.gz
+usr/share/man/man1/fc-scan.1.gz
+usr/share/man/man5/fonts-conf.5.gz
+@comment non-empty directory listing in revers order
+@dirrm usr/share/doc/fontconfig-2.8.0