aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/manu-gothica/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/manu-gothica/Makefile')
-rw-r--r--x11-fonts/manu-gothica/Makefile27
1 files changed, 10 insertions, 17 deletions
diff --git a/x11-fonts/manu-gothica/Makefile b/x11-fonts/manu-gothica/Makefile
index 2c3b2c759063..0e7c36681f89 100644
--- a/x11-fonts/manu-gothica/Makefile
+++ b/x11-fonts/manu-gothica/Makefile
@@ -3,18 +3,16 @@
PORTNAME= manu-gothica
DISTVERSION= 0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-fonts
-MASTER_SITES= http://www.bryld.info/filer/
+MASTER_SITES= http://www.bryld.dk/filer/ \
+ http://www.kswla.org/KATG%20Page%20Files/
DISTNAME= manugot19
EXTRACT_SUFX= .ttf
MAINTAINER= ports@FreeBSD.org
COMMENT= Old German blackletter handwriting (Suetterlin)
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2014-03-10
-
BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -23,21 +21,16 @@ RESTRICTED= The font is free for personal use
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= ${WRKSRC}
-NO_BUILD= yes
+NO_BUILD= yes
NO_WRKSUBDIR= yes
-FONTSDIR= lib/X11/fonts/TTF/
-PLIST_SUB+= FONTSDIR=${FONTSDIR}
-NO_STAGE= yes
do-install:
- ${MKDIR} ${PREFIX}/${FONTSDIR}
- ${INSTALL_DATA} ${WRKSRC}/manugot19.ttf ${PREFIX}/${FONTSDIR}/manugot19.ttf
-
-post-install:
- @${ECHO_MSG} "===> Running fc-cache"
- -${LOCALBASE}/bin/fc-cache -f -v ${PREFIX}/${FONTSDIR}
- @${ECHO_MSG}
- @${ECHO_MSG}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} manugot19.ttf \
+ ${STAGEDIR}${DATADIR})
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/fonts/TTF
+ @${LN} -sf ${DATADIR}/manugot19.ttf \
+ ${STAGEDIR}${PREFIX}/lib/X11/fonts/TTF
.include <bsd.port.mk>