aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/sgifonts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/sgifonts/Makefile')
-rw-r--r--x11-fonts/sgifonts/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/x11-fonts/sgifonts/Makefile b/x11-fonts/sgifonts/Makefile
index 1ebe8d6d2f3b..d7d7aab0fb42 100644
--- a/x11-fonts/sgifonts/Makefile
+++ b/x11-fonts/sgifonts/Makefile
@@ -23,8 +23,9 @@ WRKSRC= ${WRKDIR}/sgi-fonts
do-extract:
@${MKDIR} ${WRKDIR}
- @rpm2cpio ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} \
- > ${WRKDIR}/sgifonts.cpio
+ @cd ${WRKDIR}; rpm2cpio ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} \
+ | cpio --extract --no-preserve-owner \
+ --preserve-modification-time --unconditional --quiet
@cd ${WRKDIR}; \
cpio --extract --no-preserve-owner \
--preserve-modification-time --unconditional --quiet \