aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/xfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/xfs/Makefile')
-rw-r--r--x11-fonts/xfs/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/x11-fonts/xfs/Makefile b/x11-fonts/xfs/Makefile
index 69954987ba16..de1419eddd92 100644
--- a/x11-fonts/xfs/Makefile
+++ b/x11-fonts/xfs/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xfs
-PORTVERSION= 1.0.5
-PORTREVISION= 1
+PORTVERSION= 1.0.8
PORTEPOCH= 1
CATEGORIES= x11-fonts
@@ -21,18 +20,16 @@ ALL_TARGET= all config
MAN1= xfs.1
-.if !defined(WITHOUT_XFS_CACHE)
-USE_XORG+= fontcacheproto x11
-CFLAGS+= -DFONTCACHE
-.else
post-patch:
+ ${REINPLACE_CMD} '/^config_DATA/d' ${WRKSRC}/Makefile.in
+.if defined(WITHOUT_XFS_CACHE)
${REINPLACE_CMD} -e 's|^cache|XCOMM &|' ${WRKSRC}/config.cpp
.endif
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/config ${PREFIX}/lib/X11/fs/config.default
- @if [ ! -f ${PREFIX}/lib/X11/fs/config ]; then \
- ${INSTALL_SCRIPT} ${WRKSRC}/config ${PREFIX}/lib/X11/fs/config; \
+ ${INSTALL_SCRIPT} ${WRKSRC}/config ${PREFIX}/etc/X11/fs/config.default
+ @if [ ! -f ${PREFIX}/etc/X11/fs/config ]; then \
+ ${INSTALL_SCRIPT} ${WRKSRC}/config ${PREFIX}/etc/X11/fs/config; \
fi
.include <bsd.port.mk>