aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/xfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/xfs/Makefile')
-rw-r--r--x11-fonts/xfs/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/x11-fonts/xfs/Makefile b/x11-fonts/xfs/Makefile
index 80dd5ab90255..f43c4ddf8b4f 100644
--- a/x11-fonts/xfs/Makefile
+++ b/x11-fonts/xfs/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xfs
-PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTVERSION= 1.1.1
PORTEPOCH= 1
CATEGORIES= x11-fonts
@@ -15,23 +14,26 @@ MAINTAINER= x11@FreeBSD.org
COMMENT= X.Org font server
XORG_CAT= app
+USE_GMAKE= yes
USE_XORG= libfs xfont xtrans
USE_RC_SUBR= xfs
-ALL_TARGET= all config
CONFIGURE_ENV+= ac_cv_path_XMLTO=""
MAN1= xfs.1
post-patch:
- ${REINPLACE_CMD} '/^config_DATA/d' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} '/^config_DATA/d' ${WRKSRC}/config/Makefile.in
.if defined(WITHOUT_XFS_CACHE)
${REINPLACE_CMD} -e 's|^cache|XCOMM &|' ${WRKSRC}/config.cpp
.endif
+post-build:
+ @cd ${WRKSRC}/config/ && ${GMAKE} config
+
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/config ${PREFIX}/etc/X11/fs/config.default
+ ${INSTALL_SCRIPT} ${WRKSRC}/config/config ${PREFIX}/etc/X11/fs/config.default
@if [ ! -f ${PREFIX}/etc/X11/fs/config ]; then \
- ${INSTALL_SCRIPT} ${WRKSRC}/config ${PREFIX}/etc/X11/fs/config; \
+ ${INSTALL_SCRIPT} ${WRKSRC}/config/config ${PREFIX}/etc/X11/fs/config; \
fi
.include <bsd.port.mk>