aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/noto-serif-ethiopic/Makefile28
-rw-r--r--x11-fonts/noto-serif-ethiopic/distinfo3
-rw-r--r--x11-fonts/noto-serif-ethiopic/pkg-descr12
-rw-r--r--x11-fonts/noto-serif-ethiopic/pkg-plist36
5 files changed, 80 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index f728f5447b90..4c7ae6dc5ea1 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -231,6 +231,7 @@
SUBDIR += noto-serif-bengali
SUBDIR += noto-serif-devanagari
SUBDIR += noto-serif-display
+ SUBDIR += noto-serif-ethiopic
SUBDIR += noto-serif-hk
SUBDIR += noto-serif-jp
SUBDIR += noto-serif-kr
diff --git a/x11-fonts/noto-serif-ethiopic/Makefile b/x11-fonts/noto-serif-ethiopic/Makefile
new file mode 100644
index 000000000000..c6b8a234567c
--- /dev/null
+++ b/x11-fonts/noto-serif-ethiopic/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= noto
+PORTVERSION= 2.102
+CATEGORIES= x11-fonts
+MASTER_SITES= https://github.com/notofonts/ethiopic/releases/download/NotoSerifEthiopic-v${PORTVERSION}/
+PKGNAMESUFFIX= -serif-ethiopic
+DISTNAME= NotoSerifEthiopic-v${PORTVERSION}
+DIST_SUBDIR= Noto
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Google Noto Serif Ethiopic
+WWW= https://fonts.google.com/noto \
+ https://notofonts.github.io/ \
+ https://github.com/notofonts/ethiopic
+
+LICENSE= OFL11
+#LICENSE_FILE= ${WRKSRC}/OFL.txt
+
+USES= fonts zip
+
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/NotoSerifEthiopic/hinted/ttf/*.ttf ${STAGEDIR}${FONTSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/noto-serif-ethiopic/distinfo b/x11-fonts/noto-serif-ethiopic/distinfo
new file mode 100644
index 000000000000..60b995c1061f
--- /dev/null
+++ b/x11-fonts/noto-serif-ethiopic/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1710676109
+SHA256 (Noto/NotoSerifEthiopic-v2.102.zip) = 2cd163ed52f333c26fc2a55822ab1cabe875b782d73f9d55dfe5863d9e236c26
+SIZE (Noto/NotoSerifEthiopic-v2.102.zip) = 23415065
diff --git a/x11-fonts/noto-serif-ethiopic/pkg-descr b/x11-fonts/noto-serif-ethiopic/pkg-descr
new file mode 100644
index 000000000000..9aa306103442
--- /dev/null
+++ b/x11-fonts/noto-serif-ethiopic/pkg-descr
@@ -0,0 +1,12 @@
+When text is rendered by a computer, sometimes characters are displayed as
+"tofu". They are little boxes to indicate your device doesn't have a font to
+display the text.
+
+Google has been developing a font family called Noto, which aims to support all
+languages with a harmonious look and feel. Noto is Google's answer to tofu. The
+name noto is to convey the idea that Google's goal is to see no more "tofu".
+Noto has multiple styles and weights, and is freely available to all. The
+comprehensive set of fonts and tools used in our development is available in our
+GitHub repositories.
+
+This port provides the fonts set of Noto Serif Ethiopic.
diff --git a/x11-fonts/noto-serif-ethiopic/pkg-plist b/x11-fonts/noto-serif-ethiopic/pkg-plist
new file mode 100644
index 000000000000..232b090a59e3
--- /dev/null
+++ b/x11-fonts/noto-serif-ethiopic/pkg-plist
@@ -0,0 +1,36 @@
+%%FONTSDIR%%/NotoSerifEthiopic-Black.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-Bold.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-Condensed.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-CondensedBlack.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-CondensedBold.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-CondensedExtraBold.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-CondensedExtraLight.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-CondensedLight.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-CondensedMedium.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-CondensedSemiBold.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-CondensedThin.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-ExtraBold.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-ExtraCondensed.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-ExtraCondensedBlack.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-ExtraCondensedBold.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-ExtraCondensedExtraBold.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-ExtraCondensedExtraLight.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-ExtraCondensedLight.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-ExtraCondensedMedium.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-ExtraCondensedSemiBold.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-ExtraCondensedThin.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-ExtraLight.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-Light.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-Medium.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-Regular.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-SemiBold.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-SemiCondensed.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-SemiCondensedBlack.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-SemiCondensedBold.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-SemiCondensedExtraBold.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-SemiCondensedExtraLight.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-SemiCondensedLight.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-SemiCondensedMedium.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-SemiCondensedSemiBold.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-SemiCondensedThin.ttf
+%%FONTSDIR%%/NotoSerifEthiopic-Thin.ttf