aboutsummaryrefslogtreecommitdiff
path: root/x11-servers/XFree86-4-PrintServer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-servers/XFree86-4-PrintServer/Makefile')
-rw-r--r--x11-servers/XFree86-4-PrintServer/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/x11-servers/XFree86-4-PrintServer/Makefile b/x11-servers/XFree86-4-PrintServer/Makefile
index d1ea78b0885f..445b8d052554 100644
--- a/x11-servers/XFree86-4-PrintServer/Makefile
+++ b/x11-servers/XFree86-4-PrintServer/Makefile
@@ -8,15 +8,13 @@
PORTNAME= PrintServer
PORTVERSION= 4.2.0
CATEGORIES= x11-servers
-MASTER_SITES= ${MASTER_SITE_XFREE} \
- ftp://psych.psy.uq.oz.au/pub/X11R5/:wrap \
- ftp://ftp.internat.freebsd.org/pub/FreeBSD/X11-Crypto/:wrap \
- ftp://ftp3.za.freebsd.org/pub/FreeBSD/X11-Crypto/:wrap
-MASTER_SITE_SUBDIR= ${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_XFREE:S/$/:x/} \
+ ${MASTER_SITE_LOCAL:S/$/:local/}
+MASTER_SITE_SUBDIR= ${PORTVERSION}/:x \
+ anholt/:local
PKGNAMEPREFIX= XFree86-
-DISTFILES= X${PORTVERSION:S/.//g}src-1.tgz Wraphelp.c:wrap
+DISTFILES= X${PORTVERSION:S/.//g}src-1.tgz:x Wraphelp.gz:local
EXTRACT_ONLY= X${PORTVERSION:S/.//g}src-1.tgz
-IGNOREFILES= Wraphelp.c
MAINTAINER= anholt@freebsd.org
@@ -30,7 +28,8 @@ ALL_TARGET= FreeBSDPortsBuild
INSTALL_TARGET= installXprt
post-extract:
- ${CP} ${DISTDIR}/${DIST_SUBDIR}/Wraphelp.c ${WRKSRC}/lib/Xdmcp/
+ ${GUNZIP_CMD} -c ${DISTDIR}/${DIST_SUBDIR}/Wraphelp.gz > \
+ ${WRKSRC}/lib/Xdmcp/Wraphelp.c
do-configure:
cd ${.CURDIR} && ${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure