aboutsummaryrefslogtreecommitdiff
path: root/x11-servers/xorg-nestserver/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-servers/xorg-nestserver/Makefile')
-rw-r--r--x11-servers/xorg-nestserver/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/x11-servers/xorg-nestserver/Makefile b/x11-servers/xorg-nestserver/Makefile
index 14b2118ad4c2..f7a4d17bafab 100644
--- a/x11-servers/xorg-nestserver/Makefile
+++ b/x11-servers/xorg-nestserver/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= xorg-nestserver
-PORTVERSION= 1.5.3
+PORTVERSION= 1.6.0
PORTEPOCH= 1
-PORTREVISION= 1
+#PORTREVISION= 1
CATEGORIES= x11-servers
MAINTAINER= x11@FreeBSD.org
@@ -26,10 +26,11 @@ USE_XORG= x11 xf86driproto glproto randrproto renderproto fixesproto \
xf86vidmodeproto xf86bigfontproto scrnsaverproto bigreqsproto \
dri2proto resourceproto fontsproto xf86dgaproto videoproto \
compositeproto trapproto recordproto resourceproto \
- xineramaproto evieproto xkbfile xfont fontenc xkbui \
+ xineramaproto xinerama evieproto xkbfile xfont fontenc xkbui \
xxf86misc xxf86vm xaw7 xmu xpm xext pixman xtrans
-CONFIGURE_ARGS= --disable-dmx --disable-xvfb --disable-xorg --disable-xprint \
+USE_OPENSSL= yes
+CONFIGURE_ARGS= --disable-dmx --disable-xvfb --disable-xorg \
--localstatedir=/var --without-dtrace
PLIST_FILES= bin/Xnest
@@ -39,4 +40,13 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hw/xnest/Xnest ${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/hw/xnest/Xnest.1 ${PREFIX}/man/man1/
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_OPENSSL_BASE)
+# The reason why I use this is cause openssl from base doesn't install a .pc file
+# and configure will fail trying to find it. Setting both of those variables to
+# a *non-empty* value by-passes the pkg-config check.
+CONFIGURE_ENV= SHA1_LIB="-L/usr/lib -lcrypto" SHA1_CFLAGS="-I/usr/include"
+.endif
+
+.include <bsd.port.post.mk>