aboutsummaryrefslogtreecommitdiff
path: root/x11-servers
diff options
context:
space:
mode:
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/xorg-server/Makefile1
-rw-r--r--x11-servers/xorg-server/files/patch-CVE-2006-074520
2 files changed, 21 insertions, 0 deletions
diff --git a/x11-servers/xorg-server/Makefile b/x11-servers/xorg-server/Makefile
index be20706fa6c6..f8e6b5089906 100644
--- a/x11-servers/xorg-server/Makefile
+++ b/x11-servers/xorg-server/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xorg-server
PORTVERSION= 6.9.0
+PORTREVISION= 1
CATEGORIES= x11-servers
MASTER_SITES= ${MASTER_SITE_XORG}
MASTER_SITE_SUBDIR= X11R${PORTVERSION}/src
diff --git a/x11-servers/xorg-server/files/patch-CVE-2006-0745 b/x11-servers/xorg-server/files/patch-CVE-2006-0745
new file mode 100644
index 000000000000..afb7d4de763d
--- /dev/null
+++ b/x11-servers/xorg-server/files/patch-CVE-2006-0745
@@ -0,0 +1,20 @@
+--- programs/Xserver/hw/xfree86/common/xf86Init.c.orig 2006-03-17 23:30:10.000000000 +0200
++++ programs/Xserver/hw/xfree86/common/xf86Init.c 2006-03-17 23:29:35.000000000 +0200
+@@ -1376,7 +1376,7 @@
+ }
+
+ /* First the options that are only allowed for root */
+- if (getuid() == 0 || geteuid != 0)
++ if (getuid() == 0 || geteuid() != 0)
+ {
+ if (!strcmp(argv[i], "-modulepath"))
+ {
+@@ -1679,7 +1679,7 @@
+ }
+ if (!strcmp(argv[i], "-configure"))
+ {
+- if (getuid() != 0 && geteuid == 0) {
++ if (getuid() != 0 && geteuid() == 0) {
+ ErrorF("The '-configure' option can only be used by root.\n");
+ exit(1);
+ }