aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/emerald-themes/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/emerald-themes/Makefile')
-rw-r--r--x11-themes/emerald-themes/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/x11-themes/emerald-themes/Makefile b/x11-themes/emerald-themes/Makefile
index b78d74622f96..a96d5175a867 100644
--- a/x11-themes/emerald-themes/Makefile
+++ b/x11-themes/emerald-themes/Makefile
@@ -6,20 +6,19 @@
#
PORTNAME= emerald-themes
-PORTVERSION= 0.5.2
+PORTVERSION= 0.6.0
CATEGORIES= x11-themes
-MASTER_SITES= http://releases.compiz-fusion.org/${PORTVERSION}/
+MASTER_SITES= http://cgit.compiz.org/fusion/decorators/emerald-themes/snapshot/
MAINTAINER= ports@FreeBSD.org
COMMENT= Themes for the Emerald Window Decorator
-BROKEN= does not fetch
-
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf:env automake:env aclocal:env autoheader:env
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -28,4 +27,7 @@ post-patch:
@${REINPLACE_CMD} 's|/bin/bash|${LOCALBASE}/bin/bash|' \
${WRKSRC}/themes/import.sh
+pre-configure:
+ @cd ${WRKSRC} && ./autogen.sh
+
.include <bsd.port.mk>