aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/etoile-azbackground/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/etoile-azbackground/Makefile')
-rw-r--r--x11-themes/etoile-azbackground/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-themes/etoile-azbackground/Makefile b/x11-themes/etoile-azbackground/Makefile
new file mode 100644
index 000000000000..f7e5799b63b8
--- /dev/null
+++ b/x11-themes/etoile-azbackground/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: etoile-azbackground
+# Date created: 22 Dec 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= azbackground
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= x11-themes
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~%%SUBDIR%%/distfiles/
+MASTER_SITE_SUBDIR= dinoex
+PKGNAMEPREFIX= etoile-
+DISTNAME= Etoile-${SNAPSHOT}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Small GNUstep application to set xwindow background
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_SYSTEM_LIBS+= XWindowServerKit:${XWINDOWSERVERKIT_PORT}
+
+SNAPSHOT= 20061221
+WRKSRC= ${WRKDIR}/Etoile/
+USE_GNUSTEP_MAKE_DIRS+= Services/Private/AZBackground
+ADDITIONAL_OBJCFLAGS+= -I${X11BASE}/include
+ADDITIONAL_LDFLAGS+= -L${X11BASE}/lib
+
+XWINDOWSERVERKIT_PORT?= x11/etoile-xwindowserverkit
+
+.include <bsd.port.mk>