aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gnome-art/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gnome-art/Makefile')
-rw-r--r--x11-themes/gnome-art/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/x11-themes/gnome-art/Makefile b/x11-themes/gnome-art/Makefile
index 00e65f10ddf6..43b20a86d37f 100644
--- a/x11-themes/gnome-art/Makefile
+++ b/x11-themes/gnome-art/Makefile
@@ -19,11 +19,20 @@ WRKSRC= ${WRKDIR}/${PORTNAME}/${PORTNAME}
USE_RUBY= yes
USE_REINPLACE= yes
USE_RUBY_SETUP= yes
+GNOMEART_ICON= ${DATADIR}/glade/pixmaps/gnome-graphics.png
post-patch:
+ @${SED} -e 's|%%COMMENT%%|${COMMENT}|; \
+ s|%%GNOMEART_ICON%%|${GNOMEART_ICON}|' \
+ < ${FILESDIR}/gnome-art.desktop.in \
+ > ${WRKDIR}/gnome-art.desktop
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|' \
${WRKSRC}/lib/gnome-art/ui/main_window.rb \
${WRKSRC}/lib/gnome-art/ui/download_dialog.rb
@${FIND} ${WRKSRC} -name '*.bak' -delete
+post-install:
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKDIR}/gnome-art.desktop ${PREFIX}/share/applications
+
.include <bsd.port.mk>