aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gnome-icons/bsd.gnome-icons.mk
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gnome-icons/bsd.gnome-icons.mk')
-rw-r--r--x11-themes/gnome-icons/bsd.gnome-icons.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-themes/gnome-icons/bsd.gnome-icons.mk b/x11-themes/gnome-icons/bsd.gnome-icons.mk
new file mode 100644
index 000000000000..51ffa0244054
--- /dev/null
+++ b/x11-themes/gnome-icons/bsd.gnome-icons.mk
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Gnome iconset
+# Date created: 29 Feb 2004
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+#
+
+# Port logic gratuitously stolen from x11-themes/kde-icons-noia by
+# lioux@.
+
+PKGNAMEPREFIX= gnome-icons-
+MASTER_SITES?= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR?= teams/art.gnome.org/themes/icon
+
+NO_BUILD= yes
+USE_SIZE= yes
+
+REASON= Themes may contain artwork not done by the author. \
+ Keep FreeBSD safe if theme author violated copyrights.
+
+USE_X_PREFIX= yes
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/icons/${PORTNAME}
+ cd ${WRKSRC} && ${FIND} . -type d ! -empty \
+ -exec ${MKDIR} -m 0755 \
+ ${PREFIX}/share/icons/${PORTNAME}/"{}" \;
+ cd ${WRKSRC} && ${FIND} . -type f \
+ -exec ${INSTALL_DATA} ${WRKSRC}/"{}" \
+ ${PREFIX}/share/icons/${PORTNAME}/"{}" \;