aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gnome-themes/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gnome-themes/Makefile')
-rw-r--r--x11-themes/gnome-themes/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/x11-themes/gnome-themes/Makefile b/x11-themes/gnome-themes/Makefile
index 8888d0c79b9f..6bdb1fd624e3 100644
--- a/x11-themes/gnome-themes/Makefile
+++ b/x11-themes/gnome-themes/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnome-themes
-PORTVERSION= 2.2
-PORTREVISION= 1
+PORTVERSION= 2.2.1
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.2
@@ -24,7 +23,12 @@ RUN_DEPENDS= ${X11BASE}/lib/gtk-2.0/2.2.0/engines/libthinice.so:${PORTSDIR}/x11-
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
USE_LIBTOOL= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|noinst_PROGRAMS = |noinst_PROGRAMS = #|g'
+
.include <bsd.port.mk>