aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gtk-engines-collection/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-engines-collection/Makefile')
-rw-r--r--x11-themes/gtk-engines-collection/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-collection/Makefile b/x11-themes/gtk-engines-collection/Makefile
new file mode 100644
index 000000000000..816bb190e99d
--- /dev/null
+++ b/x11-themes/gtk-engines-collection/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gtk-engines-collection
+# Date created: 13 June 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtk-engines-collection
+PORTVERSION= 1.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= sobomax@FreeBSD.org
+
+# I intentionally did not put gtk-engines in the list below because
+# this package is uterly buggy.
+RUN_DEPENDS= ${THEMESBASE}/libclean.so:${PORTSDIR}/x11-toolkits/clean-theme-gtk \
+ ${THEMESBASE}/libgnomelook.so:${PORTSDIR}/x11-toolkits/gnome-look \
+ ${THEMESBASE}/libstep.so:${PORTSDIR}/x11-toolkits/gtkstep \
+ ${THEMESBASE}/libsteppastel.so:${PORTSDIR}/x11-toolkits/gtkstep-pastel \
+ ${THEMESBASE}/libthinice.so:${PORTSDIR}/x11-toolkits/thinice \
+ ${THEMESBASE}/libxeno.so:${PORTSDIR}/x11-toolkits/xenophilia
+
+THEMESBASE= ${X11BASE}/lib/gtk/themes/engines
+
+NO_BUILD= yes
+
+do-install: # empty
+
+.include <bsd.port.mk>