aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gtk-qt-engine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-qt-engine/Makefile')
-rw-r--r--x11-themes/gtk-qt-engine/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-themes/gtk-qt-engine/Makefile b/x11-themes/gtk-qt-engine/Makefile
new file mode 100644
index 000000000000..990a921af5c4
--- /dev/null
+++ b/x11-themes/gtk-qt-engine/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: gtk-qt-engine
+# Date created: 23 February 2004
+# Whom: Danny Pansters <danny@ricin.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtk-qt-engine
+PORTVERSION= 0.3
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://www.freedesktop.org/Software/gtk-qt/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= The GTK-QT Theme Engine allows GTK2 to use QT widget styles
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL_VER= 13
+WANT_GNOME= no
+USE_GNOME= gnomehack gtk20
+USE_QT_VER= 3
+USE_GCC= 3.3
+USE_REINPLACE= yes
+
+PLIST_SUB= GTK_VER=2.4.0
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+pre-configure:
+ @${RM} -f ${WRKSRC}/config.cache
+ @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/configure
+
+post-install:
+ @${ECHO_MSG}
+ @${SED} -e "s:/usr/X11R6:${PREFIX}:" ${FILESDIR}/pkg-message.in \
+ > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>