aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/eel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/eel/Makefile')
-rw-r--r--x11-toolkits/eel/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/x11-toolkits/eel/Makefile b/x11-toolkits/eel/Makefile
index 607b75d2472a..b8ea1e7c1397 100644
--- a/x11-toolkits/eel/Makefile
+++ b/x11-toolkits/eel/Makefile
@@ -19,18 +19,16 @@ LIB_DEPENDS= rsvg.1:${PORTSDIR}/graphics/librsvg
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gnomehier gnomelibs gnomevfs
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-shared --enable-static
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>